summaryrefslogtreecommitdiffstats
path: root/Tests/GeneratorExpression/CMakeLists.txt
diff options
context:
space:
mode:
authorMarc Chevrier <marc.chevrier@sap.com>2018-01-29 10:44:54 (GMT)
committerMarc Chevrier <marc.chevrier@sap.com>2018-02-07 09:57:18 (GMT)
commit5089f560e706733084d8c9bae34778a31dfe3110 (patch)
tree3c51b8f93c3ad26caf83391078c04257082656db /Tests/GeneratorExpression/CMakeLists.txt
parent5656ebc87cab02762d242326c6e5397393e671d7 (diff)
downloadCMake-5089f560e706733084d8c9bae34778a31dfe3110.zip
CMake-5089f560e706733084d8c9bae34778a31dfe3110.tar.gz
CMake-5089f560e706733084d8c9bae34778a31dfe3110.tar.bz2
Genex: Add IN_LIST logical operator
Implements #17679
Diffstat (limited to 'Tests/GeneratorExpression/CMakeLists.txt')
-rw-r--r--Tests/GeneratorExpression/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/Tests/GeneratorExpression/CMakeLists.txt b/Tests/GeneratorExpression/CMakeLists.txt
index 19d12e5..3d08704 100644
--- a/Tests/GeneratorExpression/CMakeLists.txt
+++ b/Tests/GeneratorExpression/CMakeLists.txt
@@ -57,6 +57,11 @@ add_custom_target(check-part1 ALL
-Dtest_strequal_angle_r_comma=$<STREQUAL:$<ANGLE-R>,$<COMMA>>
-Dtest_strequal_both_empty=$<STREQUAL:,>
-Dtest_strequal_one_empty=$<STREQUAL:something,>
+ -Dtest_inlist_true=$<IN_LIST:a,a$<SEMICOLON>b>
+ -Dtest_inlist_false=$<IN_LIST:c,a$<SEMICOLON>b>
+ -Dtest_inlist_empty_1=$<IN_LIST:a,>
+ -Dtest_inlist_empty_2=$<IN_LIST:,a>
+ -Dtest_inlist_empty_3=$<IN_LIST:,>
-Dtest_angle_r=$<ANGLE-R>
-Dtest_comma=$<COMMA>
-Dtest_semicolon=$<SEMICOLON>