summaryrefslogtreecommitdiffstats
path: root/Tests/GeneratorExpression/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Maynard <robert.maynard@kitware.com>2019-05-29 18:55:45 (GMT)
committerBrad King <brad.king@kitware.com>2019-06-03 14:20:23 (GMT)
commit9fd602bfd33479b1acecd40e5c1b76ce37d59798 (patch)
treef2370c6b6f736fa6b8cb2ce72f1934b4c43de212 /Tests/GeneratorExpression/CMakeLists.txt
parentec66af2026e085e7b648b222794f0f213183ea1e (diff)
downloadCMake-9fd602bfd33479b1acecd40e5c1b76ce37d59798.zip
CMake-9fd602bfd33479b1acecd40e5c1b76ce37d59798.tar.gz
CMake-9fd602bfd33479b1acecd40e5c1b76ce37d59798.tar.bz2
Genex: PlatformId now can match against a list of ids.
Diffstat (limited to 'Tests/GeneratorExpression/CMakeLists.txt')
-rw-r--r--Tests/GeneratorExpression/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/GeneratorExpression/CMakeLists.txt b/Tests/GeneratorExpression/CMakeLists.txt
index 5ba0dc0..3ff2b85 100644
--- a/Tests/GeneratorExpression/CMakeLists.txt
+++ b/Tests/GeneratorExpression/CMakeLists.txt
@@ -220,6 +220,7 @@ add_custom_target(check-part3 ALL
-Dtest_early_termination_2=$<$<1:>:,
-Dsystem_name=${CMAKE_HOST_SYSTEM_NAME}
-Dtest_platform_id=$<PLATFORM_ID>
+ -Dtest_platform_id_supported=$<PLATFORM_ID:Linux,Windows,Darwin>
-Dtest_platform_id_Linux=$<PLATFORM_ID:Linux>
-Dtest_platform_id_Windows=$<PLATFORM_ID:Windows>
-Dtest_platform_id_Darwin=$<PLATFORM_ID:Darwin>