summaryrefslogtreecommitdiffstats
path: root/Tests/GhsMulti/GhsMultiDuplicateSourceFilenames/CMakeLists.txt
diff options
context:
space:
mode:
authorFred Baksik <frodak17@gmail.com>2019-01-05 16:01:20 (GMT)
committerFred Baksik <frodak17@gmail.com>2019-01-16 15:41:03 (GMT)
commit5cef3c61fc815393248762c14ba1878aae68394d (patch)
treef50de502f49e9c7dc43ec2195d3951a955cf4399 /Tests/GhsMulti/GhsMultiDuplicateSourceFilenames/CMakeLists.txt
parenta42e40e78dc3d9c4289a3c9640cae94ecd034373 (diff)
downloadCMake-5cef3c61fc815393248762c14ba1878aae68394d.zip
CMake-5cef3c61fc815393248762c14ba1878aae68394d.tar.gz
CMake-5cef3c61fc815393248762c14ba1878aae68394d.tar.bz2
GHS: Update test suite
-- Update test suite so that CMake can use multiple toolsets CMake_TEST_GreenHillsMULTI_config ghs_config_name ghs_target_arch ghs_tools ghs_toolset_name ghs_os_root ghs_os_dir ghs_target_platform ghs_bsp_name -- Change ARM Integrity test to generic Integrity test Add Monolithic build test -- Add other GHS generator tests
Diffstat (limited to 'Tests/GhsMulti/GhsMultiDuplicateSourceFilenames/CMakeLists.txt')
-rw-r--r--Tests/GhsMulti/GhsMultiDuplicateSourceFilenames/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/Tests/GhsMulti/GhsMultiDuplicateSourceFilenames/CMakeLists.txt b/Tests/GhsMulti/GhsMultiDuplicateSourceFilenames/CMakeLists.txt
new file mode 100644
index 0000000..520e65f
--- /dev/null
+++ b/Tests/GhsMulti/GhsMultiDuplicateSourceFilenames/CMakeLists.txt
@@ -0,0 +1,17 @@
+cmake_minimum_required(VERSION 3.5)
+project(test C)
+
+add_library(libdemo
+ test.c
+ testCase.c
+ subfolder_test.c
+ subfolder_test_0.c
+ "subfolder/test.c"
+ subfolder/testcase.c
+)
+
+add_executable(demo main.c)
+target_link_libraries(demo libdemo)
+if(GHSMULTI)
+ target_compile_options(demo PUBLIC "-non_shared")
+endif()