summaryrefslogtreecommitdiffstats
path: root/Tests/ISPC/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Maynard <robert.maynard@kitware.com>2020-12-10 21:08:24 (GMT)
committerBrad King <brad.king@kitware.com>2020-12-14 18:13:09 (GMT)
commitc9a50f35565dcc1df8bd82126ecced95e60c29e4 (patch)
treeede35e80def43d76af7378632f05115c0b43bea7 /Tests/ISPC/CMakeLists.txt
parent6aff058ab4a2d54a316dbaa536572ad71efb8b51 (diff)
downloadCMake-c9a50f35565dcc1df8bd82126ecced95e60c29e4.zip
CMake-c9a50f35565dcc1df8bd82126ecced95e60c29e4.tar.gz
CMake-c9a50f35565dcc1df8bd82126ecced95e60c29e4.tar.bz2
ISPC: Generated Headers suffix configurable with a better default
The target property `ISPC_HEADER_SUFFIX` and associated global variable now can control the suffix used when generating the C/C++ interoperability ISPC headers. In addition the default suffix is now "_ispc.h" which matches the common convention that the ISPC compiler team uses and recommends.
Diffstat (limited to 'Tests/ISPC/CMakeLists.txt')
-rw-r--r--Tests/ISPC/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/ISPC/CMakeLists.txt b/Tests/ISPC/CMakeLists.txt
index 2c3651d..c993275 100644
--- a/Tests/ISPC/CMakeLists.txt
+++ b/Tests/ISPC/CMakeLists.txt
@@ -7,6 +7,7 @@ macro (add_ispc_test_macro name)
endmacro ()
add_ispc_test_macro(ISPC.ChainedStaticLibraries ISPCChainedStaticLibraries)
+add_ispc_test_macro(ISPC.CustomHeaderSuffix ISPCCustomHeaderSuffix)
add_ispc_test_macro(ISPC.Defines ISPCDefines)
add_ispc_test_macro(ISPC.DynamicLibrary ISPCDynamicLibrary)
add_ispc_test_macro(ISPC.ObjectGenex ISPCObjectGenex)