summaryrefslogtreecommitdiffstats
path: root/Tests/ISPC/SystemIncludes/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2020-12-15 12:40:26 (GMT)
committerKitware Robot <kwrobot@kitware.com>2020-12-15 12:40:34 (GMT)
commit7932e0a46e88e1a99133d1bf6f2aa36fc6136bf6 (patch)
treeb569ce857c4429b1f788305e4074db66f6a27326 /Tests/ISPC/SystemIncludes/CMakeLists.txt
parent795c5fe239e7956c41037ab477c8bd6b110a095f (diff)
parentc9a50f35565dcc1df8bd82126ecced95e60c29e4 (diff)
downloadCMake-7932e0a46e88e1a99133d1bf6f2aa36fc6136bf6.zip
CMake-7932e0a46e88e1a99133d1bf6f2aa36fc6136bf6.tar.gz
CMake-7932e0a46e88e1a99133d1bf6f2aa36fc6136bf6.tar.bz2
Merge topic 'ispc_control_header_suffixes' into release-3.19
c9a50f3556 ISPC: Generated Headers suffix configurable with a better default Acked-by: Kitware Robot <kwrobot@kitware.com> Merge-request: !5597
Diffstat (limited to 'Tests/ISPC/SystemIncludes/CMakeLists.txt')
-rw-r--r--Tests/ISPC/SystemIncludes/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Tests/ISPC/SystemIncludes/CMakeLists.txt b/Tests/ISPC/SystemIncludes/CMakeLists.txt
index 95959b2..d94e75e 100644
--- a/Tests/ISPC/SystemIncludes/CMakeLists.txt
+++ b/Tests/ISPC/SystemIncludes/CMakeLists.txt
@@ -4,8 +4,10 @@ project(ispc_spaces_in_path ISPC CXX)
add_executable(ISPCSystemIncludes main.cxx simple.ispc)
set_target_properties(ISPCSystemIncludes PROPERTIES POSITION_INDEPENDENT_CODE ON)
+set_target_properties(ISPCSystemIncludes PROPERTIES ISPC_HEADER_SUFFIX ".ispc.h")
target_include_directories(ISPCSystemIncludes SYSTEM PRIVATE "${CMAKE_CURRENT_BINARY_DIR}")
+
target_compile_options(ISPCSystemIncludes PRIVATE "$<$<COMPILE_LANGUAGE:ISPC>:--target=sse2-i32x4>")
if(CMAKE_SIZEOF_VOID_P EQUAL 4)
target_compile_options(ISPCSystemIncludes PRIVATE "$<$<COMPILE_LANGUAGE:ISPC>:--arch=x86>")