summaryrefslogtreecommitdiffstats
path: root/Tests/ISPC/SystemIncludes/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Maynard <robert.maynard@kitware.com>2020-12-09 15:55:30 (GMT)
committerRobert Maynard <robert.maynard@kitware.com>2020-12-09 16:33:44 (GMT)
commit8da25e4a3c0583a940abcbfede8ceb915fd976e0 (patch)
treece4042e286216ed4dce40120af99677c973a80e2 /Tests/ISPC/SystemIncludes/CMakeLists.txt
parent64fb825438a2fecb9eab9933d5d1b926bf6f294b (diff)
downloadCMake-8da25e4a3c0583a940abcbfede8ceb915fd976e0.zip
CMake-8da25e4a3c0583a940abcbfede8ceb915fd976e0.tar.gz
CMake-8da25e4a3c0583a940abcbfede8ceb915fd976e0.tar.bz2
ISPC: Treat system includes as '-I' includes
ISPC doesn't have specific syntax for system includes.
Diffstat (limited to 'Tests/ISPC/SystemIncludes/CMakeLists.txt')
-rw-r--r--Tests/ISPC/SystemIncludes/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/Tests/ISPC/SystemIncludes/CMakeLists.txt b/Tests/ISPC/SystemIncludes/CMakeLists.txt
new file mode 100644
index 0000000..95959b2
--- /dev/null
+++ b/Tests/ISPC/SystemIncludes/CMakeLists.txt
@@ -0,0 +1,12 @@
+cmake_minimum_required(VERSION 3.18)
+project(ispc_spaces_in_path ISPC CXX)
+
+
+add_executable(ISPCSystemIncludes main.cxx simple.ispc)
+set_target_properties(ISPCSystemIncludes PROPERTIES POSITION_INDEPENDENT_CODE ON)
+target_include_directories(ISPCSystemIncludes SYSTEM PRIVATE "${CMAKE_CURRENT_BINARY_DIR}")
+
+target_compile_options(ISPCSystemIncludes PRIVATE "$<$<COMPILE_LANGUAGE:ISPC>:--target=sse2-i32x4>")
+if(CMAKE_SIZEOF_VOID_P EQUAL 4)
+ target_compile_options(ISPCSystemIncludes PRIVATE "$<$<COMPILE_LANGUAGE:ISPC>:--arch=x86>")
+endif()