summaryrefslogtreecommitdiffstats
path: root/Tests/ISPC/SystemIncludes/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2020-12-10 11:56:54 (GMT)
committerKitware Robot <kwrobot@kitware.com>2020-12-10 11:57:04 (GMT)
commit9f66eb74a5edbb9480614aecd1e2c8cb915a6bd8 (patch)
tree8c814dea0430ea3a42b294f34a9b7c5b432c14ad /Tests/ISPC/SystemIncludes/CMakeLists.txt
parent8a3ecb484fb04aa9fb8b9f6d198b3a6942c26115 (diff)
parent8da25e4a3c0583a940abcbfede8ceb915fd976e0 (diff)
downloadCMake-9f66eb74a5edbb9480614aecd1e2c8cb915a6bd8.zip
CMake-9f66eb74a5edbb9480614aecd1e2c8cb915a6bd8.tar.gz
CMake-9f66eb74a5edbb9480614aecd1e2c8cb915a6bd8.tar.bz2
Merge topic 'ispc-system-includes' into release-3.19
8da25e4a3c ISPC: Treat system includes as '-I' includes Acked-by: Kitware Robot <kwrobot@kitware.com> Merge-request: !5591
Diffstat (limited to 'Tests/ISPC/SystemIncludes/CMakeLists.txt')
-rw-r--r--Tests/ISPC/SystemIncludes/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/Tests/ISPC/SystemIncludes/CMakeLists.txt b/Tests/ISPC/SystemIncludes/CMakeLists.txt
new file mode 100644
index 0000000..95959b2
--- /dev/null
+++ b/Tests/ISPC/SystemIncludes/CMakeLists.txt
@@ -0,0 +1,12 @@
+cmake_minimum_required(VERSION 3.18)
+project(ispc_spaces_in_path ISPC CXX)
+
+
+add_executable(ISPCSystemIncludes main.cxx simple.ispc)
+set_target_properties(ISPCSystemIncludes PROPERTIES POSITION_INDEPENDENT_CODE ON)
+target_include_directories(ISPCSystemIncludes SYSTEM PRIVATE "${CMAKE_CURRENT_BINARY_DIR}")
+
+target_compile_options(ISPCSystemIncludes PRIVATE "$<$<COMPILE_LANGUAGE:ISPC>:--target=sse2-i32x4>")
+if(CMAKE_SIZEOF_VOID_P EQUAL 4)
+ target_compile_options(ISPCSystemIncludes PRIVATE "$<$<COMPILE_LANGUAGE:ISPC>:--arch=x86>")
+endif()