summaryrefslogtreecommitdiffstats
path: root/Tests/IncludeDirectories/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <steveire@gmail.com>2013-08-22 21:52:00 (GMT)
committerStephen Kelly <steveire@gmail.com>2013-08-24 13:14:56 (GMT)
commiteef6df5c7d97680f9c20729555c061cf3e2b2482 (patch)
tree853a767941f7524064f29ea928568f608c84a799 /Tests/IncludeDirectories/CMakeLists.txt
parent374af6529a08fc1c9c9c16e5d55929c450db6e35 (diff)
downloadCMake-eef6df5c7d97680f9c20729555c061cf3e2b2482.zip
CMake-eef6df5c7d97680f9c20729555c061cf3e2b2482.tar.gz
CMake-eef6df5c7d97680f9c20729555c061cf3e2b2482.tar.bz2
Fix OLD behavior of CMP0021.
Exclude Ninja and Xcode from the CMP0021 test They do not behave the same as the makefile generator with relative paths. Don't overwrite the header file for in-source builds.
Diffstat (limited to 'Tests/IncludeDirectories/CMakeLists.txt')
-rw-r--r--Tests/IncludeDirectories/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/IncludeDirectories/CMakeLists.txt b/Tests/IncludeDirectories/CMakeLists.txt
index 596a280..35ad8dc 100644
--- a/Tests/IncludeDirectories/CMakeLists.txt
+++ b/Tests/IncludeDirectories/CMakeLists.txt
@@ -86,3 +86,7 @@ get_target_property(incs empty_entry_test INCLUDE_DIRECTORIES)
if (NOT incs STREQUAL ";/one/two")
message(SEND_ERROR "Empty include_directories entry was not ignored.")
endif()
+
+if(NOT CMAKE_GENERATOR STREQUAL Xcode AND NOT CMAKE_GENERATOR STREQUAL Ninja)
+ add_subdirectory(CMP0021)
+endif()