summaryrefslogtreecommitdiffstats
path: root/Tests/InterfaceLibrary/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <steveire@gmail.com>2013-12-30 13:35:08 (GMT)
committerStephen Kelly <steveire@gmail.com>2014-01-06 16:25:10 (GMT)
commit7461d67cf37a40ce5a6c20e8eaf4cbfff1c7d27e (patch)
treee09a7efebac382478ed1392cec6c59c2bd391a79 /Tests/InterfaceLibrary/CMakeLists.txt
parent7fc6e3d607c79c1124b2ac93fac0dcddc326ef66 (diff)
downloadCMake-7461d67cf37a40ce5a6c20e8eaf4cbfff1c7d27e.zip
CMake-7461d67cf37a40ce5a6c20e8eaf4cbfff1c7d27e.tar.gz
CMake-7461d67cf37a40ce5a6c20e8eaf4cbfff1c7d27e.tar.bz2
cmTarget: Enable convenient include dir handling for INTERFACE_LIBRARY.
Make the CMAKE_INCLUDE_CURRENT_DIR_IN_INTERFACE variable affect INTERFACE_LIBRARY targets.
Diffstat (limited to 'Tests/InterfaceLibrary/CMakeLists.txt')
-rw-r--r--Tests/InterfaceLibrary/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/Tests/InterfaceLibrary/CMakeLists.txt b/Tests/InterfaceLibrary/CMakeLists.txt
index 8154ced..396a84a 100644
--- a/Tests/InterfaceLibrary/CMakeLists.txt
+++ b/Tests/InterfaceLibrary/CMakeLists.txt
@@ -6,8 +6,10 @@ project(InterfaceLibrary)
add_library(iface_nodepends INTERFACE)
target_compile_definitions(iface_nodepends INTERFACE IFACE_DEFINE)
+add_subdirectory(headerdir)
+
add_executable(InterfaceLibrary definetestexe.cpp)
-target_link_libraries(InterfaceLibrary iface_nodepends)
+target_link_libraries(InterfaceLibrary iface_nodepends headeriface)
add_subdirectory(libsdir)