summaryrefslogtreecommitdiffstats
path: root/Tests/LinkDirectory/CMakeLists.txt
diff options
context:
space:
mode:
authorKyle Edwards <kyle.edwards@kitware.com>2019-11-15 14:57:38 (GMT)
committerKitware Robot <kwrobot@kitware.com>2019-11-15 14:57:56 (GMT)
commit5695b0464b411746b207da2ee23b8e2d9f8ffec2 (patch)
tree82e1a00666f6e8a026b7af578801b9b38d8e04ce /Tests/LinkDirectory/CMakeLists.txt
parent1d78e1a966912d35e1dea0e986bc0b977141e880 (diff)
parent2d0100fac7a51327ce8053b4ab2277aaa96c12a5 (diff)
downloadCMake-5695b0464b411746b207da2ee23b8e2d9f8ffec2.zip
CMake-5695b0464b411746b207da2ee23b8e2d9f8ffec2.tar.gz
CMake-5695b0464b411746b207da2ee23b8e2d9f8ffec2.tar.bz2
Merge topic 'cmake-e-rm'
2d0100fac7 replace remove and remove_directory with rm in tests 5239fc5c75 cmake -E: Add rm with improved semantics over remove and remove_directory Acked-by: Kitware Robot <kwrobot@kitware.com> Merge-request: !3949
Diffstat (limited to 'Tests/LinkDirectory/CMakeLists.txt')
-rw-r--r--Tests/LinkDirectory/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/LinkDirectory/CMakeLists.txt b/Tests/LinkDirectory/CMakeLists.txt
index c60de84..c7a2700 100644
--- a/Tests/LinkDirectory/CMakeLists.txt
+++ b/Tests/LinkDirectory/CMakeLists.txt
@@ -33,7 +33,7 @@ ExternalProject_Add(ExternalTarget
# directly because it does not know the full paths to the libraries.
# (The purpose of this test is to check that link_directories works.)
ExternalProject_Add_Step(ExternalTarget cleanup
- COMMAND ${CMAKE_COMMAND} -E remove_directory ${LinkDirectory_BINARY_DIR}/bin
+ COMMAND ${CMAKE_COMMAND} -E rm -rf ${LinkDirectory_BINARY_DIR}/bin
DEPENDEES download
DEPENDERS configure
DEPENDS mylibA mylibB