summaryrefslogtreecommitdiffstats
path: root/Tests/LoadCommand/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-06-25 19:26:18 (GMT)
committerBrad King <brad.king@kitware.com>2014-06-25 19:27:01 (GMT)
commit5c105140594389841e8db65365b066fa12f666c5 (patch)
treed383da7980fd26831c8977cb7016592920aa401e /Tests/LoadCommand/CMakeLists.txt
parentb1cbd577c172a946f9097f13902f505ba62087bc (diff)
downloadCMake-5c105140594389841e8db65365b066fa12f666c5.zip
CMake-5c105140594389841e8db65365b066fa12f666c5.tar.gz
CMake-5c105140594389841e8db65365b066fa12f666c5.tar.bz2
Tests: Simplify LoadCommand tests
Drop out-of-place coverage of CheckFunctionExists module. The "printf" symbol is not available on VS 14 without including the <stdio.h> header to get a definition.
Diffstat (limited to 'Tests/LoadCommand/CMakeLists.txt')
-rw-r--r--Tests/LoadCommand/CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/Tests/LoadCommand/CMakeLists.txt b/Tests/LoadCommand/CMakeLists.txt
index c933798..03a3b49 100644
--- a/Tests/LoadCommand/CMakeLists.txt
+++ b/Tests/LoadCommand/CMakeLists.txt
@@ -8,10 +8,6 @@ include (${CMAKE_ROOT}/Modules/CheckTypeSize.cmake)
CHECK_TYPE_SIZE(char SIZEOF_CHAR)
CHECK_TYPE_SIZE(short SIZEOF_SHORT)
-include (CheckFunctionExists)
-CHECK_FUNCTION_EXISTS(printf HAVE_PRINTF)
-CHECK_FUNCTION_EXISTS(vsblabla HAVE_VSBLABLA)
-
configure_file(${LoadCommand_SOURCE_DIR}/LoadedCommand.h.in
${LoadCommand_BINARY_DIR}/LoadedCommand.h)