summaryrefslogtreecommitdiffstats
path: root/Tests/MakeClean/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniele E. Domenichelli <daniele.domenichelli@iit.it>2013-11-13 08:50:56 (GMT)
committerBrad King <brad.king@kitware.com>2013-11-13 15:12:17 (GMT)
commit15610bb5b16a4f39202a84a6f6ef1a22b17170df (patch)
tree68b5a742022fed31c873a5906c1769167acb26a1 /Tests/MakeClean/CMakeLists.txt
parent706aab0418f40e9816be5270e5b4e89321411e2d (diff)
downloadCMake-15610bb5b16a4f39202a84a6f6ef1a22b17170df.zip
CMake-15610bb5b16a4f39202a84a6f6ef1a22b17170df.tar.gz
CMake-15610bb5b16a4f39202a84a6f6ef1a22b17170df.tar.bz2
Drop use of configure_file IMMEDIATE option
Since commit 7d47c693 (Drop compatibility with CMake < 2.4, 2013-10-08) we no longer need to use the configure_file IMMEDIATE option to support compatibility modes less than 2.0.
Diffstat (limited to 'Tests/MakeClean/CMakeLists.txt')
-rw-r--r--Tests/MakeClean/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/MakeClean/CMakeLists.txt b/Tests/MakeClean/CMakeLists.txt
index 13348a2..1308b61 100644
--- a/Tests/MakeClean/CMakeLists.txt
+++ b/Tests/MakeClean/CMakeLists.txt
@@ -37,7 +37,7 @@ foreach(f ${TOCLEAN_FILES})
set(CHECK_FILES "${CHECK_FILES} \"${f}\",\n")
endforeach()
configure_file(${MakeClean_SOURCE_DIR}/check_clean.c.in
- ${MakeClean_BINARY_DIR}/check_clean.c @ONLY IMMEDIATE)
+ ${MakeClean_BINARY_DIR}/check_clean.c @ONLY)
add_executable(check_clean ${MakeClean_BINARY_DIR}/check_clean.c)
# After the executable builds, clean the files.