summaryrefslogtreecommitdiffstats
path: root/Tests/Module/WriteCompilerDetectionHeader/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2015-01-11 17:00:22 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2015-01-11 17:00:22 (GMT)
commit1c0d6a7cb5c51fef3ee8804ed298da95e2c1ca1a (patch)
tree5bd4ce690ac0fa03fa0b1a16afdda6bb120ba43b /Tests/Module/WriteCompilerDetectionHeader/CMakeLists.txt
parentcb5fc7b993866e7398922d34a1b1807ad061d4b0 (diff)
parenta15675efc3d96906d4e803def2e83fd3bd1cf812 (diff)
downloadCMake-1c0d6a7cb5c51fef3ee8804ed298da95e2c1ca1a.zip
CMake-1c0d6a7cb5c51fef3ee8804ed298da95e2c1ca1a.tar.gz
CMake-1c0d6a7cb5c51fef3ee8804ed298da95e2c1ca1a.tar.bz2
Merge topic 'refactor-CompileFeatures-test'
a15675ef Features: Quote all compiler names when comparing with COMPILER_ID 07d1f6fc Features: Properly evaluate if the compiler supports cxx_final. 6296192d Features: Add a comment explaining part of test. c13656e7 Features: Test nullptr as a side-effect activation of static_assert. 3e34e833 Features: Test feature propagation with more-common features. b3e86f4e Features: Test an expectation of whether OVERRIDE_CONTROL is expected
Diffstat (limited to 'Tests/Module/WriteCompilerDetectionHeader/CMakeLists.txt')
-rw-r--r--Tests/Module/WriteCompilerDetectionHeader/CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/Tests/Module/WriteCompilerDetectionHeader/CMakeLists.txt b/Tests/Module/WriteCompilerDetectionHeader/CMakeLists.txt
index 5b2f1de..401de95 100644
--- a/Tests/Module/WriteCompilerDetectionHeader/CMakeLists.txt
+++ b/Tests/Module/WriteCompilerDetectionHeader/CMakeLists.txt
@@ -1,4 +1,4 @@
-cmake_minimum_required(VERSION 3.0.0)
+cmake_minimum_required(VERSION 3.1.0)
project(WriteCompilerDetectionHeader)
set(CMAKE_INCLUDE_CURRENT_DIR ON)
@@ -56,17 +56,17 @@ macro(set_defines target true_defs false_defs)
)
endmacro()
-if (CMAKE_CXX_COMPILER_ID STREQUAL GNU
- OR CMAKE_CXX_COMPILER_ID STREQUAL Clang
- OR CMAKE_CXX_COMPILER_ID STREQUAL AppleClang)
+if (CMAKE_CXX_COMPILER_ID STREQUAL "GNU"
+ OR CMAKE_CXX_COMPILER_ID STREQUAL "Clang"
+ OR CMAKE_CXX_COMPILER_ID STREQUAL "AppleClang")
# False for C++98 mode.
list(APPEND false_defs EXPECTED_COMPILER_CXX_DELEGATING_CONSTRUCTORS)
list(APPEND false_defs EXPECTED_COMPILER_CXX_VARIADIC_TEMPLATES)
endif()
-if (CMAKE_C_COMPILER_ID STREQUAL GNU
- OR CMAKE_C_COMPILER_ID STREQUAL Clang
- OR CMAKE_C_COMPILER_ID STREQUAL AppleClang)
+if (CMAKE_C_COMPILER_ID STREQUAL "GNU"
+ OR CMAKE_C_COMPILER_ID STREQUAL "Clang"
+ OR CMAKE_C_COMPILER_ID STREQUAL "AppleClang")
add_executable(C_undefined c_undefined.c)
set_property(TARGET C_undefined PROPERTY CXX_STANDARD 90)
target_compile_options(C_undefined PRIVATE -Werror=undef)