summaryrefslogtreecommitdiffstats
path: root/Tests/ModuleDefinition/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-10-05 18:39:23 (GMT)
committerBrad King <brad.king@kitware.com>2009-10-05 18:39:23 (GMT)
commitf1b7e620f7fa867ee50eb50ad398d349281691fe (patch)
tree9aae3f9e305e838a034d52a95e1fe43fdecdf569 /Tests/ModuleDefinition/CMakeLists.txt
parent667f0724a87ea5fa5f71c475f7588a9deab75ebb (diff)
downloadCMake-f1b7e620f7fa867ee50eb50ad398d349281691fe.zip
CMake-f1b7e620f7fa867ee50eb50ad398d349281691fe.tar.gz
CMake-f1b7e620f7fa867ee50eb50ad398d349281691fe.tar.bz2
Fix ModuleDefinition test for Intel on Windows
CMake defines MSVC only for a VS compiler, but the Intel compiler adds the preprocessor definition _MSC_VER. Instead of relying on separate tests to decide whether to use example_dll_2, we do one test in CMake and then add our own preprocessor definition.
Diffstat (limited to 'Tests/ModuleDefinition/CMakeLists.txt')
-rw-r--r--Tests/ModuleDefinition/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/Tests/ModuleDefinition/CMakeLists.txt b/Tests/ModuleDefinition/CMakeLists.txt
index 0cef0c7..b463a3c 100644
--- a/Tests/ModuleDefinition/CMakeLists.txt
+++ b/Tests/ModuleDefinition/CMakeLists.txt
@@ -5,10 +5,11 @@ project(ModuleDefinition C)
add_library(example_dll SHARED example_dll.c example_dll.def)
# Test /DEF:<file> flag recognition for VS.
-if(MSVC)
+if(MSVC OR "${CMAKE_C_COMPILER_ID}" MATCHES "^(Intel)$")
add_library(example_dll_2 SHARED example_dll_2.c)
set_property(TARGET example_dll_2 PROPERTY LINK_FLAGS
/DEF:"${ModuleDefinition_SOURCE_DIR}/example_dll_2.def")
+ set_property(DIRECTORY APPEND PROPERTY COMPILE_DEFINITIONS EXAMPLE_DLL_2)
set(example_dll_2 example_dll_2)
endif()