summaryrefslogtreecommitdiffstats
path: root/Tests/ObjectLibrary/A/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Cole <david.cole@kitware.com>2012-03-21 17:27:10 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2012-03-21 17:27:10 (GMT)
commit7e94e6b52550d333557a013232e0e8e5a3381047 (patch)
treeacd1a20d9a8807dd78312329293df21fecc5259c /Tests/ObjectLibrary/A/CMakeLists.txt
parenta72893da36ce5a78043b333e4bd430df2fdb323d (diff)
parentfb7348f64455242dcbbb3837c697c9bf88414ae2 (diff)
downloadCMake-7e94e6b52550d333557a013232e0e8e5a3381047.zip
CMake-7e94e6b52550d333557a013232e0e8e5a3381047.tar.gz
CMake-7e94e6b52550d333557a013232e0e8e5a3381047.tar.bz2
Merge topic 'watcom-object-library'
fb7348f Fix ObjectLibrary test on Watcom
Diffstat (limited to 'Tests/ObjectLibrary/A/CMakeLists.txt')
-rw-r--r--Tests/ObjectLibrary/A/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/Tests/ObjectLibrary/A/CMakeLists.txt b/Tests/ObjectLibrary/A/CMakeLists.txt
index e0a620e..121a8ac 100644
--- a/Tests/ObjectLibrary/A/CMakeLists.txt
+++ b/Tests/ObjectLibrary/A/CMakeLists.txt
@@ -1,10 +1,10 @@
# Add -fPIC so objects can be used in shared libraries.
# TODO: Need property for this.
-if(CMAKE_SHARED_LIBRARY_C_FLAGS)
+if(CMAKE_SHARED_LIBRARY_C_FLAGS AND NOT WATCOM)
set(CMAKE_C_FLAGS "${CMAKE_SHARED_LIBRARY_C_FLAGS} ${CMAKE_C_FLAGS}")
endif()
-add_definitions(-DA)
+add_definitions(-DA_DEF)
add_custom_command(
OUTPUT a1.c