summaryrefslogtreecommitdiffstats
path: root/Tests/ObjectLibrary/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2016-03-09 14:42:18 (GMT)
committerBrad King <brad.king@kitware.com>2016-03-09 14:42:18 (GMT)
commitb42866a34a742f89a35382d17d58070c73486d92 (patch)
tree5728aef86df7ff0d6a677875b442d12147da2e46 /Tests/ObjectLibrary/CMakeLists.txt
parentcd9ba3ec453d547b15ab761e20793a1a17bbbd8d (diff)
downloadCMake-b42866a34a742f89a35382d17d58070c73486d92.zip
CMake-b42866a34a742f89a35382d17d58070c73486d92.tar.gz
CMake-b42866a34a742f89a35382d17d58070c73486d92.tar.bz2
Drop Visual Studio 6 generator
This generator has been deprecated since CMake 3.3. Remove it. Update documentation, modules, and tests to drop content specific to this generator.
Diffstat (limited to 'Tests/ObjectLibrary/CMakeLists.txt')
-rw-r--r--Tests/ObjectLibrary/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/Tests/ObjectLibrary/CMakeLists.txt b/Tests/ObjectLibrary/CMakeLists.txt
index e9f553e..e3476df 100644
--- a/Tests/ObjectLibrary/CMakeLists.txt
+++ b/Tests/ObjectLibrary/CMakeLists.txt
@@ -16,8 +16,8 @@ add_custom_command(TARGET UseCshared POST_BUILD COMMAND ${CMAKE_COMMAND} -P ${CM
add_executable(UseCinternal main.c c.c $<TARGET_OBJECTS:A> $<TARGET_OBJECTS:B>)
-if("${CMAKE_GENERATOR}" MATCHES "^Visual Studio (6|7|7 .NET 2003)$")
- # VS 6 and 7 generators do not add objects as sources so we need a
+if("${CMAKE_GENERATOR}" MATCHES "^Visual Studio (7|7 .NET 2003)$")
+ # VS 7 generators do not add objects as sources so we need a
# dummy object to convince the IDE to build the targets below.
set(dummy dummy.obj) # In MinGW: gcc -c dummy.c -o dummy.obj
elseif("${CMAKE_GENERATOR}" MATCHES "Xcode")