summaryrefslogtreecommitdiffstats
path: root/Tests/ObjectLibrary/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2021-05-26 14:56:10 (GMT)
committerBrad King <brad.king@kitware.com>2021-05-29 13:28:36 (GMT)
commit3941555d935afad8343c66f39579bfc611201a6f (patch)
tree4f5b55b32aa25a56fb6f6f10ba896585878e6331 /Tests/ObjectLibrary/CMakeLists.txt
parentf530b3a26729d0820c804e312b72e0061d6eeb4b (diff)
downloadCMake-3941555d935afad8343c66f39579bfc611201a6f.zip
CMake-3941555d935afad8343c66f39579bfc611201a6f.tar.gz
CMake-3941555d935afad8343c66f39579bfc611201a6f.tar.bz2
target_link_libraries: Place $<TARGET_OBJECTS> before libraries
Linkers always use object files explicitly specified on the command line regardless of where they appear. Move them to the front of the list of linked libraries in so that symbols required by the object files can be resolved by any library. Issue: #22149
Diffstat (limited to 'Tests/ObjectLibrary/CMakeLists.txt')
-rw-r--r--Tests/ObjectLibrary/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Tests/ObjectLibrary/CMakeLists.txt b/Tests/ObjectLibrary/CMakeLists.txt
index 74f34e4..06167a8 100644
--- a/Tests/ObjectLibrary/CMakeLists.txt
+++ b/Tests/ObjectLibrary/CMakeLists.txt
@@ -74,4 +74,6 @@ target_link_libraries(UseABstaticObjs ABstatic)
add_subdirectory(ExportLanguages)
+add_subdirectory(LinkObjects)
+
add_subdirectory(Transitive)