summaryrefslogtreecommitdiffstats
path: root/Tests/ObjectLibrary/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2020-03-04 17:58:29 (GMT)
committerBrad King <brad.king@kitware.com>2020-03-04 18:04:00 (GMT)
commit3b3de0fd17d45f1927a28b4c52ba5146325b1bb0 (patch)
tree3fc85a5344abb0e0d6544e804ad11eb629464290 /Tests/ObjectLibrary/CMakeLists.txt
parent07a7bc0e3fc370eaa5593cffcd07c0ea739cfc9c (diff)
downloadCMake-3b3de0fd17d45f1927a28b4c52ba5146325b1bb0.zip
CMake-3b3de0fd17d45f1927a28b4c52ba5146325b1bb0.tar.gz
CMake-3b3de0fd17d45f1927a28b4c52ba5146325b1bb0.tar.bz2
Tests: Extend ObjectLibrary test with case for object lib dependencies
Add the test case from commit bab24e782c (target_link_libraries: Propagate dependencies of object libraries, 2018-12-10, v3.14.0-rc1~260^2) to the main ObjectLibrary test.
Diffstat (limited to 'Tests/ObjectLibrary/CMakeLists.txt')
-rw-r--r--Tests/ObjectLibrary/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Tests/ObjectLibrary/CMakeLists.txt b/Tests/ObjectLibrary/CMakeLists.txt
index 7897ab9..fca5f41 100644
--- a/Tests/ObjectLibrary/CMakeLists.txt
+++ b/Tests/ObjectLibrary/CMakeLists.txt
@@ -73,3 +73,5 @@ add_executable(UseABstaticObjs $<TARGET_OBJECTS:UseABstatic>)
target_link_libraries(UseABstaticObjs ABstatic)
add_subdirectory(ExportLanguages)
+
+add_subdirectory(Transitive)