summaryrefslogtreecommitdiffstats
path: root/Tests/OutOfSource/CMakeLists.txt
diff options
context:
space:
mode:
authorKen Martin <ken.martin@kitware.com>2005-09-13 14:40:38 (GMT)
committerKen Martin <ken.martin@kitware.com>2005-09-13 14:40:38 (GMT)
commitfd26d148d8b71871bc5abe2f4e48b56d142d6be0 (patch)
tree3eeb7dd3ed158b669f0676efc3dea857585711b8 /Tests/OutOfSource/CMakeLists.txt
parent2a45d5cd684c835f6e97c28ef997ef5824f4827d (diff)
downloadCMake-fd26d148d8b71871bc5abe2f4e48b56d142d6be0.zip
CMake-fd26d148d8b71871bc5abe2f4e48b56d142d6be0.tar.gz
CMake-fd26d148d8b71871bc5abe2f4e48b56d142d6be0.tar.bz2
ENH: test get directory properties ability to get props from subdirs
Diffstat (limited to 'Tests/OutOfSource/CMakeLists.txt')
-rw-r--r--Tests/OutOfSource/CMakeLists.txt15
1 files changed, 11 insertions, 4 deletions
diff --git a/Tests/OutOfSource/CMakeLists.txt b/Tests/OutOfSource/CMakeLists.txt
index e6c4f97..a053f14 100644
--- a/Tests/OutOfSource/CMakeLists.txt
+++ b/Tests/OutOfSource/CMakeLists.txt
@@ -1,6 +1,13 @@
-# a simple test case
-PROJECT (OutOfSource)
+# a simple test cas
+project (OutOfSource)
-ADD_SUBDIRECTORY(SubDir)
+add_subdirectory(SubDir)
-SET(KEN 1)
+get_directory_property(ANIMAL DIRECTORY OutOfSourceSubdir DEFINITION WEASELS)
+
+configure_file(
+ ${OutOfSource_SOURCE_DIR}/testdp.h.in
+ ${OutOfSource_BINARY_DIR}/SubDir/OutOfSourceSubdir/testdp.h
+ )
+
+set(KEN 1)