summaryrefslogtreecommitdiffstats
path: root/Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2006-10-10 01:25:58 (GMT)
committerBrad King <brad.king@kitware.com>2006-10-10 01:25:58 (GMT)
commit0fe0523810b1408c94c722ebae8aa47429d55d6d (patch)
tree68f23b45ce5d356e1649275532a1b00fa2015ce6 /Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt
parent9fca6a7837a41ed7dc0f891abdbc32a4a118f2aa (diff)
downloadCMake-0fe0523810b1408c94c722ebae8aa47429d55d6d.zip
CMake-0fe0523810b1408c94c722ebae8aa47429d55d6d.tar.gz
CMake-0fe0523810b1408c94c722ebae8aa47429d55d6d.tar.bz2
BUG: Fixed out-of-source subdirectories to work when they are also out-of-binary. Updated the OutOfSource test to test this feature.
Diffstat (limited to 'Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt')
-rw-r--r--Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt b/Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt
index 02ab4f6..bbdaa55 100644
--- a/Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt
+++ b/Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt
@@ -4,7 +4,7 @@ IF ("${PROJECT_SOURCE_DIR}" STREQUAL "${ANOTHER_PROJ_SOURCE_DIR}")
SET(BUILD_SHARED_LIBS 1)
ADD_LIBRARY(testlib testlib.cxx)
ADD_EXECUTABLE (simple simple.cxx ../simple.cxx)
- TARGET_LINK_LIBRARIES(simple testlib)
+ TARGET_LINK_LIBRARIES(simple testlib outlib)
ENDIF ("${PROJECT_SOURCE_DIR}" STREQUAL "${ANOTHER_PROJ_SOURCE_DIR}")
# test getting a definition from a subdir