summaryrefslogtreecommitdiffstats
path: root/Tests/PDBDirectoryAndName/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-10-21 19:08:07 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2014-10-21 19:08:07 (GMT)
commit95d84f76d9a8e27eb974fce7d06b7f2e312a05e6 (patch)
tree727105aeb6ebba64c18a3af64c207e50cf900104 /Tests/PDBDirectoryAndName/CMakeLists.txt
parentc8ba39719409dc106f76c0b67f805158be01b3b4 (diff)
parent29c3edb87adedd82e816552d958f4c3540a1511b (diff)
downloadCMake-95d84f76d9a8e27eb974fce7d06b7f2e312a05e6.zip
CMake-95d84f76d9a8e27eb974fce7d06b7f2e312a05e6.tar.gz
CMake-95d84f76d9a8e27eb974fce7d06b7f2e312a05e6.tar.bz2
Merge topic 'cmake-cmp0054-warnings'
29c3edb8 Avoid if() quoted auto-dereference
Diffstat (limited to 'Tests/PDBDirectoryAndName/CMakeLists.txt')
-rw-r--r--Tests/PDBDirectoryAndName/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/PDBDirectoryAndName/CMakeLists.txt b/Tests/PDBDirectoryAndName/CMakeLists.txt
index 90af600..180f9fe 100644
--- a/Tests/PDBDirectoryAndName/CMakeLists.txt
+++ b/Tests/PDBDirectoryAndName/CMakeLists.txt
@@ -2,7 +2,7 @@ cmake_minimum_required(VERSION 2.8)
project(PDBDirectoryAndName C)
# Make sure the proper compiler is in use.
-if(NOT MSVC AND NOT "${CMAKE_C_COMPILER_ID}" MATCHES "^(Intel)$")
+if(NOT MSVC AND NOT CMAKE_C_COMPILER_ID STREQUAL "Intel")
message(FATAL_ERROR "The PDBDirectoryAndName test works only with MSVC or Intel")
endif()