summaryrefslogtreecommitdiffstats
path: root/Tests/Plugin/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-06-15 14:55:21 (GMT)
committerBrad King <brad.king@kitware.com>2009-06-15 14:55:21 (GMT)
commitf4b3bdc6bef35e10791e6dd013edd58f70d0b33a (patch)
tree772e1d9d0f30c0ff3eb657c7744d2b0fad177c7b /Tests/Plugin/CMakeLists.txt
parentd30923d6313856bf1b05cb093514947437f6e8b5 (diff)
downloadCMake-f4b3bdc6bef35e10791e6dd013edd58f70d0b33a.zip
CMake-f4b3bdc6bef35e10791e6dd013edd58f70d0b33a.tar.gz
CMake-f4b3bdc6bef35e10791e6dd013edd58f70d0b33a.tar.bz2
BUG: Create an exe's implib output dir for VS
If an executable marks symbols with __declspec(dllexport) then VS creates an import library for it. However, it forgets to create the directory that will contain the import library if it is different from the location of the executable. We work around this VS bug by creating a pre-build event on the executable target to make the directory.
Diffstat (limited to 'Tests/Plugin/CMakeLists.txt')
-rw-r--r--Tests/Plugin/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Tests/Plugin/CMakeLists.txt b/Tests/Plugin/CMakeLists.txt
index 2245a8a..38347a97 100644
--- a/Tests/Plugin/CMakeLists.txt
+++ b/Tests/Plugin/CMakeLists.txt
@@ -34,6 +34,8 @@ ADD_EXECUTABLE(example_exe src/example_exe.cxx)
SET_TARGET_PROPERTIES(example_exe PROPERTIES
ENABLE_EXPORTS 1
OUTPUT_NAME example
+ # Test placing exe import library in unique directory.
+ ARCHIVE_OUTPUT_DIRECTORY ${CMAKE_ARCHIVE_OUTPUT_DIRECTORY}/exe
)
TARGET_LINK_LIBRARIES(example_exe kwsys)