summaryrefslogtreecommitdiffstats
path: root/Tests/Preprocess/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-04-24 15:18:06 (GMT)
committerBrad King <brad.king@kitware.com>2009-04-24 15:18:06 (GMT)
commit708d1cf1ee9300bc9b9e26a47e1bbe1718612d6f (patch)
treeda8134e5e88176619d7ffc29ec010a9035540d5e /Tests/Preprocess/CMakeLists.txt
parent70b2f59c3f9c70c085966bacb1e8a41c3ad2947f (diff)
downloadCMake-708d1cf1ee9300bc9b9e26a47e1bbe1718612d6f.zip
CMake-708d1cf1ee9300bc9b9e26a47e1bbe1718612d6f.tar.gz
CMake-708d1cf1ee9300bc9b9e26a47e1bbe1718612d6f.tar.bz2
ENH: Support more preprocessor values in VS6
Previously we rejected all preprocessor definition values containing spaces for the VS6 IDE generator. In fact VS6 does support spaces but not in combination with '"', '$', or ';', and only if we use the sytnax '-DNAME="value with spaces"' instead of '-D"NAME=value with spaces"'. Now we support all definition values that do not have one of these invalid pairs. See issue #8779.
Diffstat (limited to 'Tests/Preprocess/CMakeLists.txt')
-rw-r--r--Tests/Preprocess/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/Tests/Preprocess/CMakeLists.txt b/Tests/Preprocess/CMakeLists.txt
index bb33907..3187c36 100644
--- a/Tests/Preprocess/CMakeLists.txt
+++ b/Tests/Preprocess/CMakeLists.txt
@@ -66,8 +66,9 @@ if(NOT BORLAND AND NOT PP_VS70)
endif(NOT BORLAND AND NOT PP_VS70)
if(NOT PP_VS6)
- # VS 6 IDE: spaces
- # The project parser unconditionally separates arguments at spaces.
+ # VS 6 IDE: spaces and '"', '$', or ';'
+ # The project parser cannot handle spaces if there are quotes.
+ # Since we test passing in a quoted string, we cannot have spaces.
set(STRING_EXTRA "${STRING_EXTRA} ")
if(NOT PP_BORLAND AND NOT PP_WATCOM)