summaryrefslogtreecommitdiffstats
path: root/Tests/Qt4And5Automoc/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <steveire@gmail.com>2013-05-27 15:58:57 (GMT)
committerStephen Kelly <steveire@gmail.com>2013-05-27 23:19:37 (GMT)
commitfa55751f83dc5d5bd5f80d12c3076ec703262edb (patch)
tree7420d760cbeaad79622325d3b285a1b53d2c743f /Tests/Qt4And5Automoc/CMakeLists.txt
parentf77631672168b1e3b5fad93c2bb83db65cb67e7b (diff)
downloadCMake-fa55751f83dc5d5bd5f80d12c3076ec703262edb.zip
CMake-fa55751f83dc5d5bd5f80d12c3076ec703262edb.tar.gz
CMake-fa55751f83dc5d5bd5f80d12c3076ec703262edb.tar.bz2
QtAutomoc: Get the Qt version through the target link interface
In Qt 5.1, Qt5::Core has a INTERFACE_QT_MAJOR_VERSION property of '5', and since CMake 2.8.11, Qt4::QtCore has an INTERFACE_QT_MAJOR_VERSION of '4'. This was introduced in commit 4aa10cd6 (FindQt4: Set the INTERFACE_QT_MAJOR_VERSION for Qt4::QtCore, 2013-03-16), to produce an error if Qt 4 and Qt 5 are erroneously used by the same target. This can also be used however to determine the Qt major version, and therefore the particular moc executable to use during automoc steps. This means that targets in a single buildsystem can use a selection of Qt 4 and Qt 5, and still take advantage of the CMAKE_AUTOMOC feature without conflicting.
Diffstat (limited to 'Tests/Qt4And5Automoc/CMakeLists.txt')
-rw-r--r--Tests/Qt4And5Automoc/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/Tests/Qt4And5Automoc/CMakeLists.txt b/Tests/Qt4And5Automoc/CMakeLists.txt
new file mode 100644
index 0000000..0cc80fe
--- /dev/null
+++ b/Tests/Qt4And5Automoc/CMakeLists.txt
@@ -0,0 +1,13 @@
+
+project(Qt4And5Automoc)
+
+find_package(Qt4 REQUIRED)
+find_package(Qt5Core REQUIRED)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+add_executable(qt4_exe main_qt4.cpp)
+target_link_libraries(qt4_exe Qt4::QtCore)
+add_executable(qt5_exe main_qt5.cpp)
+target_link_libraries(qt5_exe Qt5::Core)