summaryrefslogtreecommitdiffstats
path: root/Tests/Qt4Deploy/CMakeLists.txt
diff options
context:
space:
mode:
authorCraig Scott <craig.scott@crascit.com>2017-12-29 11:17:32 (GMT)
committerCraig Scott <craig.scott@crascit.com>2017-12-29 22:35:56 (GMT)
commitc267ea1c3e54626e4ab2283dc7529ed8aa8beac8 (patch)
treee361a5bcdec7006768e3a4a79109c19efa34c9ee /Tests/Qt4Deploy/CMakeLists.txt
parent497f4bb941a84bacfca2392759de6cb8e23b0684 (diff)
downloadCMake-c267ea1c3e54626e4ab2283dc7529ed8aa8beac8.zip
CMake-c267ea1c3e54626e4ab2283dc7529ed8aa8beac8.tar.gz
CMake-c267ea1c3e54626e4ab2283dc7529ed8aa8beac8.tar.bz2
GENERATOR_IS_MULTI_CONFIG: Use for multi-config checks in Tests
Diffstat (limited to 'Tests/Qt4Deploy/CMakeLists.txt')
-rw-r--r--Tests/Qt4Deploy/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/Tests/Qt4Deploy/CMakeLists.txt b/Tests/Qt4Deploy/CMakeLists.txt
index 646ea9f..c73a38c 100644
--- a/Tests/Qt4Deploy/CMakeLists.txt
+++ b/Tests/Qt4Deploy/CMakeLists.txt
@@ -1,4 +1,4 @@
-cmake_minimum_required(VERSION 2.8)
+cmake_minimum_required(VERSION 3.9)
project(Qt4Deploy)
set(CMAKE_INSTALL_PREFIX ${CMAKE_CURRENT_BINARY_DIR}/install)
@@ -10,7 +10,8 @@ add_executable(testdeploy MACOSX_BUNDLE testdeploy.cpp)
target_link_libraries(testdeploy ${QT_LIBRARIES})
set_target_properties(testdeploy PROPERTIES INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}")
-if(CMAKE_CONFIGURATION_TYPES AND QT_QTCORE_LIBRARY_RELEASE AND QT_QTCORE_LIBRARY_DEBUG)
+get_property(_isMultiConfig GLOBAL PROPERTY GENERATOR_IS_MULTI_CONFIG)
+if(_isMultiConfig AND QT_QTCORE_LIBRARY_RELEASE AND QT_QTCORE_LIBRARY_DEBUG)
# note: installing debug Qt libraries from a Qt installation configured with
# -debug-and-release not yet supported (very low priority).
install(CODE "
@@ -58,7 +59,7 @@ if(QT_QSQLITE_PLUGIN_DEBUG OR QT_QSQLITE_PLUGIN_RELEASE)
endif()
# custom target to install and test the installation at build time
- if(CMAKE_CONFIGURATION_TYPES)
+ if(_isMultiConfig)
set(install_config "-DCMAKE_INSTALL_CONFIG_NAME=${CMAKE_CFG_INTDIR}")
endif()