summaryrefslogtreecommitdiffstats
path: root/Tests/Qt4Targets/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <steveire@gmail.com>2012-11-05 11:43:28 (GMT)
committerStephen Kelly <steveire@gmail.com>2013-01-31 16:34:20 (GMT)
commit77cecb778ff1882d87401c1055ec06585462f787 (patch)
tree7abf8c4ffc3839e6b2f8593757cd34119aea17a2 /Tests/Qt4Targets/CMakeLists.txt
parent0b92602b816e2584db3781b120a1e5200da72ada (diff)
downloadCMake-77cecb778ff1882d87401c1055ec06585462f787.zip
CMake-77cecb778ff1882d87401c1055ec06585462f787.tar.gz
CMake-77cecb778ff1882d87401c1055ec06585462f787.tar.bz2
Add includes and compile definitions with target_link_libraries.
This establishes that linking is used to propagate usage-requirements between targets in CMake code. The use of the target_link_libraries command as the API for this is chosen because introducing a new command would introduce confusion due to multiple commands which differ only in a subtle way.
Diffstat (limited to 'Tests/Qt4Targets/CMakeLists.txt')
-rw-r--r--Tests/Qt4Targets/CMakeLists.txt19
1 files changed, 0 insertions, 19 deletions
diff --git a/Tests/Qt4Targets/CMakeLists.txt b/Tests/Qt4Targets/CMakeLists.txt
index d3aba74..d0c9c66 100644
--- a/Tests/Qt4Targets/CMakeLists.txt
+++ b/Tests/Qt4Targets/CMakeLists.txt
@@ -12,29 +12,10 @@ set(CMAKE_INCLUDE_CURRENT_DIR ON)
add_executable(Qt4Targets WIN32 main.cpp)
target_link_libraries(Qt4Targets Qt4::QtGui)
-set_property(TARGET Qt4Targets APPEND PROPERTY
- INCLUDE_DIRECTORIES
- $<TARGET_PROPERTY:Qt4::QtGui,INTERFACE_INCLUDE_DIRECTORIES>
-)
-set_property(TARGET Qt4Targets APPEND PROPERTY
- COMPILE_DEFINITIONS
- $<TARGET_PROPERTY:Qt4::QtGui,INTERFACE_COMPILE_DEFINITIONS>
-)
-
if (WIN32)
if (TARGET Qt4::QAxServer)
add_executable(activeqtexe WIN32 activeqtexe.cpp)
set_property(TARGET activeqtexe PROPERTY QT4_NO_LINK_QTMAIN ON)
target_link_libraries(activeqtexe Qt4::QAxServer Qt4::QtGui)
- set_property(TARGET activeqtexe APPEND PROPERTY
- INCLUDE_DIRECTORIES
- $<TARGET_PROPERTY:Qt4::QAxServer,INTERFACE_INCLUDE_DIRECTORIES>
- $<TARGET_PROPERTY:Qt4::QtGui,INTERFACE_INCLUDE_DIRECTORIES>
- )
- set_property(TARGET activeqtexe APPEND PROPERTY
- COMPILE_DEFINITIONS
- $<TARGET_PROPERTY:Qt4::QAxServer,INTERFACE_COMPILE_DEFINITIONS>
- $<TARGET_PROPERTY:Qt4::QtGui,INTERFACE_COMPILE_DEFINITIONS>
- )
endif()
endif()