summaryrefslogtreecommitdiffstats
path: root/Tests/Qt4Targets/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <steveire@gmail.com>2012-12-31 08:41:09 (GMT)
committerBrad King <brad.king@kitware.com>2013-01-07 19:00:47 (GMT)
commit57a67bf27efc286fffa883baad86c7d5d51834cc (patch)
treee1c7bd8916be485c638dcd28c43b82df7e8c3921 /Tests/Qt4Targets/CMakeLists.txt
parent00deb127be64cf8934d92c1593c8ea4a5f0f2061 (diff)
downloadCMake-57a67bf27efc286fffa883baad86c7d5d51834cc.zip
CMake-57a67bf27efc286fffa883baad86c7d5d51834cc.tar.gz
CMake-57a67bf27efc286fffa883baad86c7d5d51834cc.tar.bz2
Qt4: Add module dependencies to the IMPORTED targets
This means for example, that consumers can use: target_link_libraries(foo ${QT_QTGUI_LIBRARIES}) instead of also needing to specify all 'public' dependencies: target_link_libraries(foo ${QT_QTGUI_LIBRARIES} ${QT_QTCORE_LIBRARIES} ) when using the IMPORTED targets. Also populate the IMPORTED_LINK_DEPENDENT_LIBRARIES property so CMake can help the linker find shared library dependencies.
Diffstat (limited to 'Tests/Qt4Targets/CMakeLists.txt')
-rw-r--r--Tests/Qt4Targets/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/Tests/Qt4Targets/CMakeLists.txt b/Tests/Qt4Targets/CMakeLists.txt
new file mode 100644
index 0000000..3adff48
--- /dev/null
+++ b/Tests/Qt4Targets/CMakeLists.txt
@@ -0,0 +1,14 @@
+cmake_minimum_required(VERSION 2.8)
+
+project(Qt4Targets)
+
+find_package(Qt4 REQUIRED)
+
+include_directories(${QT_INCLUDES})
+
+add_executable(Qt4Targets WIN32 main.cpp)
+target_link_libraries(Qt4Targets Qt4::QtGui)
+
+if (WIN32)
+ target_link_libraries(Qt4Targets Qt4::qtmain)
+endif()