summaryrefslogtreecommitdiffstats
path: root/Tests/QtAutogen/AutogenTimestampDeps/CMakeLists.txt
diff options
context:
space:
mode:
authorOrkun Tokdemir <ilhanorkuntokdemir@gmail.com>2024-01-26 11:17:14 (GMT)
committerBrad King <brad.king@kitware.com>2024-01-28 14:40:47 (GMT)
commitd0bedb217046e4fb79bff2c24b581d97451d0fd4 (patch)
treef746848de5a6c80f181c9bd59a7c48f9a6a5f82c /Tests/QtAutogen/AutogenTimestampDeps/CMakeLists.txt
parent4deb9c41b88d53247c7929de660e0cafe8d8d25c (diff)
downloadCMake-d0bedb217046e4fb79bff2c24b581d97451d0fd4.zip
CMake-d0bedb217046e4fb79bff2c24b581d97451d0fd4.tar.gz
CMake-d0bedb217046e4fb79bff2c24b581d97451d0fd4.tar.bz2
Autogen: Forward dependencies when both Makefile and DEPFILE are used
Since commit ebc9e448b3 (Autogen: Add depfile support for Makefiles, 2023-09-07, v3.28.0-rc1~101^2~1) CMake does not generate the correct dependency graph when both `Makefile` and `DEPFILE` are used. The build of `<target_name>_autogen_timestamp_deps` fails due to missing dependencies. To tackle that problem, forward target dependencies to both `<target_name>_autogen_timestamp_deps` and `<target_name>_autogen` instead of just `<target_name>_autogen`. Fixes: #25600
Diffstat (limited to 'Tests/QtAutogen/AutogenTimestampDeps/CMakeLists.txt')
-rw-r--r--Tests/QtAutogen/AutogenTimestampDeps/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/Tests/QtAutogen/AutogenTimestampDeps/CMakeLists.txt b/Tests/QtAutogen/AutogenTimestampDeps/CMakeLists.txt
new file mode 100644
index 0000000..3470a02
--- /dev/null
+++ b/Tests/QtAutogen/AutogenTimestampDeps/CMakeLists.txt
@@ -0,0 +1,11 @@
+cmake_minimum_required(VERSION 3.28)
+project(AutogenTimestampDeps)
+include("../AutogenCoreTest.cmake")
+
+set(CMAKE_AUTOMOC ON)
+
+add_custom_target(ProjectInfo
+ COMMAND ${CMAKE_COMMAND} -P ${CMAKE_CURRENT_SOURCE_DIR}/cmake/UpdateProjectInfo.cmake
+ BYPRODUCTS ${CMAKE_BINARY_DIR}/ProjectInfo.hpp)
+
+add_subdirectory(src)