summaryrefslogtreecommitdiffstats
path: root/Tests/QtAutogen/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2016-07-21 13:08:43 (GMT)
committerBrad King <brad.king@kitware.com>2016-07-21 13:27:19 (GMT)
commit5e55d87bdc4d14507fec2bae7a41f3fb9498db1a (patch)
tree5836ad2a646a2ee22fc6a2ebd39f229f9338251b /Tests/QtAutogen/CMakeLists.txt
parente31084e65745f9dd422c6aff0a2ed4ada6918805 (diff)
downloadCMake-5e55d87bdc4d14507fec2bae7a41f3fb9498db1a.zip
CMake-5e55d87bdc4d14507fec2bae7a41f3fb9498db1a.tar.gz
CMake-5e55d87bdc4d14507fec2bae7a41f3fb9498db1a.tar.bz2
Autogen: Revert changes to generate moc/rcc in subdirectories
Revert these commits: * v3.6.0-rc1~134^2 Tests: QtAutogen: Same source name in different directories test, 2016-04-13 * v3.6.0-rc1~134^2~1 Autogen: Generate qrc_NAME.cpp files in subdirectories, 2016-04-19 * v3.6.0-rc1~134^2~2 Autogen: Generate not included moc files in subdirectories, 2016-04-19 They regress existing builds that depend on the paths/symbols generated previously. Another approach will be needed to solve the name collision problem they were intended to solve. Leave the error diagnostics for the colliding cases that were added in the same topic as the above commits because they provide a useful early failure in relevant cases. Fixes #16209.
Diffstat (limited to 'Tests/QtAutogen/CMakeLists.txt')
-rw-r--r--Tests/QtAutogen/CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/Tests/QtAutogen/CMakeLists.txt b/Tests/QtAutogen/CMakeLists.txt
index 4875165..d5aca55 100644
--- a/Tests/QtAutogen/CMakeLists.txt
+++ b/Tests/QtAutogen/CMakeLists.txt
@@ -110,10 +110,6 @@ set_target_properties(
AUTOMOC TRUE
)
-# Test AUTOMOC and AUTORCC on source files with the same name
-# but in different subdirectories
-add_subdirectory(same_name)
-
include(GenerateExportHeader)
# The order is relevant here. B depends on A, and B headers depend on A
# headers both subdirectories use CMAKE_INCLUDE_CURRENT_DIR_IN_INTERFACE and we