summaryrefslogtreecommitdiffstats
path: root/Tests/QtAutogen/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastian Holtermann <sebholt@xwmw.org>2016-08-06 13:22:54 (GMT)
committerBrad King <brad.king@kitware.com>2016-08-10 17:21:34 (GMT)
commite4f508e42397549cd966e47349d4030cb793c354 (patch)
tree2d18a87082f3aa21b0f1115e9c54b07a21bac3dc /Tests/QtAutogen/CMakeLists.txt
parent4e9b97d7397fd526e6b4e4ce43dd305cb8341ac8 (diff)
downloadCMake-e4f508e42397549cd966e47349d4030cb793c354.zip
CMake-e4f508e42397549cd966e47349d4030cb793c354.tar.gz
CMake-e4f508e42397549cd966e47349d4030cb793c354.tar.bz2
Tests/QtAutogen: Test same moc/qrc source names in different directories
Diffstat (limited to 'Tests/QtAutogen/CMakeLists.txt')
-rw-r--r--Tests/QtAutogen/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/QtAutogen/CMakeLists.txt b/Tests/QtAutogen/CMakeLists.txt
index d5aca55..e35e1d1 100644
--- a/Tests/QtAutogen/CMakeLists.txt
+++ b/Tests/QtAutogen/CMakeLists.txt
@@ -110,6 +110,10 @@ set_target_properties(
AUTOMOC TRUE
)
+# Test AUTOMOC and AUTORCC on source files with the same name
+# but in different subdirectories
+add_subdirectory(sameName)
+
include(GenerateExportHeader)
# The order is relevant here. B depends on A, and B headers depend on A
# headers both subdirectories use CMAKE_INCLUDE_CURRENT_DIR_IN_INTERFACE and we