summaryrefslogtreecommitdiffstats
path: root/Tests/QtAutogen/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2017-12-08 14:34:59 (GMT)
committerKitware Robot <kwrobot@kitware.com>2017-12-08 14:35:02 (GMT)
commit158fb9755cffa427461addcaa6da8d18ec6246c6 (patch)
treeba6b565eea56729b85f335e71463be3f41d42a75 /Tests/QtAutogen/CMakeLists.txt
parentbbac777698bf30be07a0edcc34ddc1a1e16b2dc5 (diff)
parent1bc603344725920dbc518c9e9545741edc0139d3 (diff)
downloadCMake-158fb9755cffa427461addcaa6da8d18ec6246c6.zip
CMake-158fb9755cffa427461addcaa6da8d18ec6246c6.tar.gz
CMake-158fb9755cffa427461addcaa6da8d18ec6246c6.tar.bz2
Merge topic 'autogen-fix-library-deps'
1bc60334 Merge branch 'automoc-apple-framework' into autogen-fix-library-deps a3f8371c Merge branch 'automoc-apple-framework' into autogen-fix-library-deps bd49ae51 Autogen: Fix library dependency forwarding to _autogen target e4ccc684 Autogen: Tests: Add test for MacOS frameworks fcbd02fd Autogen: Fix for AUTOMOC on macOS frameworks in CMake 3.10 Acked-by: Kitware Robot <kwrobot@kitware.com> Merge-request: !1566
Diffstat (limited to 'Tests/QtAutogen/CMakeLists.txt')
-rw-r--r--Tests/QtAutogen/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/Tests/QtAutogen/CMakeLists.txt b/Tests/QtAutogen/CMakeLists.txt
index 32c2950..dff9d0c 100644
--- a/Tests/QtAutogen/CMakeLists.txt
+++ b/Tests/QtAutogen/CMakeLists.txt
@@ -215,6 +215,12 @@ add_subdirectory(uicInclude)
add_subdirectory(objectLibrary)
# -- Test
+# MacOS Framework
+if(APPLE AND (NOT QT_TEST_VERSION STREQUAL 4))
+ add_subdirectory(macosFW)
+endif()
+
+# -- Test
# Source files with the same basename in different subdirectories
add_subdirectory(sameName)