summaryrefslogtreecommitdiffstats
path: root/Tests/QtAutogen/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastian Holtermann <sebholt@xwmw.org>2016-04-13 16:36:39 (GMT)
committerBrad King <brad.king@kitware.com>2016-04-22 12:55:44 (GMT)
commit84946c735cc6d2b8f8e014f4772dd602b4a83a16 (patch)
treef89d262df1f4346f89c1c538dd90669c4d9810be /Tests/QtAutogen/CMakeLists.txt
parent9c6fa684e7681417f5e75f25034f28212e22b229 (diff)
downloadCMake-84946c735cc6d2b8f8e014f4772dd602b4a83a16.zip
CMake-84946c735cc6d2b8f8e014f4772dd602b4a83a16.tar.gz
CMake-84946c735cc6d2b8f8e014f4772dd602b4a83a16.tar.bz2
Tests: QtAutogen: Same source name in different directories test
The test features multiple .cpp and .qrc files with the same name in different subdirectories. This requires AUTOMOC and AUTORCC to generate files with names that respect the path information of the source files.
Diffstat (limited to 'Tests/QtAutogen/CMakeLists.txt')
-rw-r--r--Tests/QtAutogen/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/QtAutogen/CMakeLists.txt b/Tests/QtAutogen/CMakeLists.txt
index d5aca55..4875165 100644
--- a/Tests/QtAutogen/CMakeLists.txt
+++ b/Tests/QtAutogen/CMakeLists.txt
@@ -110,6 +110,10 @@ set_target_properties(
AUTOMOC TRUE
)
+# Test AUTOMOC and AUTORCC on source files with the same name
+# but in different subdirectories
+add_subdirectory(same_name)
+
include(GenerateExportHeader)
# The order is relevant here. B depends on A, and B headers depend on A
# headers both subdirectories use CMAKE_INCLUDE_CURRENT_DIR_IN_INTERFACE and we