summaryrefslogtreecommitdiffstats
path: root/Tests/QtAutogen/DefinesTest/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastian Holtermann <sebholt@xwmw.org>2017-12-08 16:09:30 (GMT)
committerSebastian Holtermann <sebholt@xwmw.org>2017-12-13 12:48:27 (GMT)
commit227a7974f426e0966d1736c66dd606b068985d1b (patch)
tree1b0048d6c54e4c0d88c1313bc6bc30c3f0c18610 /Tests/QtAutogen/DefinesTest/CMakeLists.txt
parentbd10c3cf82f6e9d58b121498eaa2b9d8cc19dd2f (diff)
downloadCMake-227a7974f426e0966d1736c66dd606b068985d1b.zip
CMake-227a7974f426e0966d1736c66dd606b068985d1b.tar.gz
CMake-227a7974f426e0966d1736c66dd606b068985d1b.tar.bz2
Autogen: Tests: Add basic scripts for separate tests
Diffstat (limited to 'Tests/QtAutogen/DefinesTest/CMakeLists.txt')
-rw-r--r--Tests/QtAutogen/DefinesTest/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/Tests/QtAutogen/DefinesTest/CMakeLists.txt b/Tests/QtAutogen/DefinesTest/CMakeLists.txt
new file mode 100644
index 0000000..de22845
--- /dev/null
+++ b/Tests/QtAutogen/DefinesTest/CMakeLists.txt
@@ -0,0 +1,13 @@
+cmake_minimum_required(VERSION 3.10)
+project(DefinesTest)
+
+# Qt4 only definitions test
+if(NOT QT_TEST_VERSION STREQUAL 4)
+ message(ERROR "Invalid Qt test version. This test is for Qt4 only.")
+endif()
+
+find_package(Qt4 REQUIRED)
+
+add_executable(DefinesTest defines_test.cpp)
+set_target_properties(DefinesTest PROPERTIES AUTOMOC TRUE)
+target_link_libraries(DefinesTest Qt4::QtGui)