summaryrefslogtreecommitdiffstats
path: root/Tests/QtAutogen/GlobalAutogenExecutable/CMakeLists.txt
diff options
context:
space:
mode:
authorOrkun Tokdemir <orkun.tokdemir@qt.io>2023-03-17 17:11:38 (GMT)
committerBrad King <brad.king@kitware.com>2023-03-22 11:31:56 (GMT)
commitb3d17975087a41ad799e8f5566d50212f3f0e0b3 (patch)
treebba957ac8f06d006994ccbb752d9688bf4b27f66 /Tests/QtAutogen/GlobalAutogenExecutable/CMakeLists.txt
parent9d439e235ce117fb24822e0cb1716c785e38db19 (diff)
downloadCMake-b3d17975087a41ad799e8f5566d50212f3f0e0b3.zip
CMake-b3d17975087a41ad799e8f5566d50212f3f0e0b3.tar.gz
CMake-b3d17975087a41ad799e8f5566d50212f3f0e0b3.tar.bz2
Autogen: Add CMAKE_AUTO*_EXECUTABLE variables
Add the `CMAKE_AUTOMOC_EXECUTABLE`, `CMAKE_AUTOUIC_EXECUTABLE`, and `CMAKE_AUTORCC_EXECUTABLE` variables to initialize the corresponding `AUTO{MOC,UIC,RCC}_EXECUTABLE` target properties. Fixes: #20071
Diffstat (limited to 'Tests/QtAutogen/GlobalAutogenExecutable/CMakeLists.txt')
-rw-r--r--Tests/QtAutogen/GlobalAutogenExecutable/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/Tests/QtAutogen/GlobalAutogenExecutable/CMakeLists.txt b/Tests/QtAutogen/GlobalAutogenExecutable/CMakeLists.txt
new file mode 100644
index 0000000..34da744
--- /dev/null
+++ b/Tests/QtAutogen/GlobalAutogenExecutable/CMakeLists.txt
@@ -0,0 +1,30 @@
+cmake_minimum_required(VERSION 3.26)
+project(GlobalAutogenExecutable)
+
+include("../AutogenCoreTest.cmake")
+
+set(test_automoc_path "global_automoc_exe_path")
+set(test_autouic_path "global_autouic_exe_path")
+set(test_autorcc_path "global_autorcc_exe_path")
+
+set(CMAKE_AUTOMOC_EXECUTABLE ${test_automoc_path})
+set(CMAKE_AUTOUIC_EXECUTABLE ${test_autouic_path})
+set(CMAKE_AUTORCC_EXECUTABLE ${test_autorcc_path})
+
+add_executable(autogen_test main.cpp)
+
+get_target_property(target_automoc_path autogen_test AUTOMOC_EXECUTABLE)
+get_target_property(target_autouic_path autogen_test AUTOUIC_EXECUTABLE)
+get_target_property(target_autorcc_path autogen_test AUTORCC_EXECUTABLE)
+
+if(NOT ${target_automoc_path} STREQUAL ${test_automoc_path})
+ message(FATAL_ERROR "CMAKE_AUTOMOC_EXECUTABLE not set")
+endif()
+
+if (NOT ${target_autouic_path} STREQUAL ${test_autouic_path})
+ message(FATAL_ERROR "CMAKE_AUTOUIC_EXECUTABLE not set")
+endif()
+
+if (NOT ${target_autorcc_path} STREQUAL ${test_autorcc_path})
+ message(FATAL_ERROR "CMAKE_AUTORCC_EXECUTABLE not set")
+endif()