summaryrefslogtreecommitdiffstats
path: root/Tests/QtAutogen/MocOnly/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastian Holtermann <sebholt@xwmw.org>2017-12-08 16:29:23 (GMT)
committerSebastian Holtermann <sebholt@xwmw.org>2017-12-13 12:48:27 (GMT)
commit0b8597a86ee8bed2c34f52d309fd57b5f29a1595 (patch)
tree912e41e02cc0e562fca2caa9897e1e850359611b /Tests/QtAutogen/MocOnly/CMakeLists.txt
parent227a7974f426e0966d1736c66dd606b068985d1b (diff)
downloadCMake-0b8597a86ee8bed2c34f52d309fd57b5f29a1595.zip
CMake-0b8597a86ee8bed2c34f52d309fd57b5f29a1595.tar.gz
CMake-0b8597a86ee8bed2c34f52d309fd57b5f29a1595.tar.bz2
Autogen: Tests: Separate mocOnly and mocOnlyOpts tests
Diffstat (limited to 'Tests/QtAutogen/MocOnly/CMakeLists.txt')
-rw-r--r--Tests/QtAutogen/MocOnly/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/Tests/QtAutogen/MocOnly/CMakeLists.txt b/Tests/QtAutogen/MocOnly/CMakeLists.txt
new file mode 100644
index 0000000..33feadf
--- /dev/null
+++ b/Tests/QtAutogen/MocOnly/CMakeLists.txt
@@ -0,0 +1,8 @@
+cmake_minimum_required(VERSION 3.10)
+project(MocOnly)
+include("../AutogenTest.cmake")
+
+# Test different Q_OBJECT position styles
+add_executable(mocOnly StyleA.cpp StyleB.cpp main.cpp)
+set_property(TARGET mocOnly PROPERTY AUTOMOC ON)
+target_link_libraries(mocOnly ${QT_LIBRARIES})