summaryrefslogtreecommitdiffstats
path: root/Tests/QtAutomoc/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Neundorf <neundorf@kde.org>2011-11-22 18:19:31 (GMT)
committerAlex Neundorf <neundorf@kde.org>2011-11-22 19:52:13 (GMT)
commit30fd8e603a52b7230e0b716d8120fc01551c8a4f (patch)
treebc3c086f06a50c90a9d2a43826ee5cbce4222e8d /Tests/QtAutomoc/CMakeLists.txt
parent80dfbc99f4b04b5eaea9111fa014f07603a8db16 (diff)
downloadCMake-30fd8e603a52b7230e0b716d8120fc01551c8a4f.zip
CMake-30fd8e603a52b7230e0b716d8120fc01551c8a4f.tar.gz
CMake-30fd8e603a52b7230e0b716d8120fc01551c8a4f.tar.bz2
automoc: add test for including the moc file from another header
including moc_xyz.cpp in abc.cpp should run moc on xyz.h (and include the file in abc.cpp) Alex
Diffstat (limited to 'Tests/QtAutomoc/CMakeLists.txt')
-rw-r--r--Tests/QtAutomoc/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/QtAutomoc/CMakeLists.txt b/Tests/QtAutomoc/CMakeLists.txt
index c81ac11..9f02618 100644
--- a/Tests/QtAutomoc/CMakeLists.txt
+++ b/Tests/QtAutomoc/CMakeLists.txt
@@ -13,7 +13,7 @@ add_definitions(-DFOO)
# create an executable and a library target, both requiring automoc:
add_library(codeeditorLib STATIC codeeditor.cpp)
-add_executable(foo main.cpp calwidget.cpp foo.cpp blub.cpp bar.cpp abc.cpp)
+add_executable(foo main.cpp calwidget.cpp foo.cpp blub.cpp bar.cpp abc.cpp xyz.cpp)
set_target_properties(foo codeeditorLib PROPERTIES AUTOMOC TRUE)