summaryrefslogtreecommitdiffstats
path: root/Tests/QtAutomoc/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Neundorf <neundorf@kde.org>2011-10-22 17:38:39 (GMT)
committerAlex Neundorf <neundorf@kde.org>2011-10-22 17:38:39 (GMT)
commit56aa6ffae75dd2567d2041147774bb1a9a3a1bdf (patch)
tree378c183d5b02a87b81b667d6f6498b45e2921bb8 /Tests/QtAutomoc/CMakeLists.txt
parentaf772893b856b50697f18c9bb7b1a0fb326cf715 (diff)
downloadCMake-56aa6ffae75dd2567d2041147774bb1a9a3a1bdf.zip
CMake-56aa6ffae75dd2567d2041147774bb1a9a3a1bdf.tar.gz
CMake-56aa6ffae75dd2567d2041147774bb1a9a3a1bdf.tar.bz2
automoc:run moc on the header if the source file contains include "foo.moc"
This fixes #12533. Before automoc did not check the header if the source file contained a statement, now it does. Additionally, moc is now only run on explicitely listed headers which contain a Q_OBJECT macro. Alex
Diffstat (limited to 'Tests/QtAutomoc/CMakeLists.txt')
-rw-r--r--Tests/QtAutomoc/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/QtAutomoc/CMakeLists.txt b/Tests/QtAutomoc/CMakeLists.txt
index 4a5ff10..01f6bea 100644
--- a/Tests/QtAutomoc/CMakeLists.txt
+++ b/Tests/QtAutomoc/CMakeLists.txt
@@ -13,7 +13,7 @@ add_definitions(-DFOO)
# create an executable and a library target, both requiring automoc:
add_library(codeeditorLib STATIC codeeditor.cpp)
-add_executable(foo main.cpp calwidget.cpp )
+add_executable(foo main.cpp calwidget.cpp foo.cpp)
set_target_properties(foo codeeditorLib PROPERTIES AUTOMOC TRUE)