summaryrefslogtreecommitdiffstats
path: root/Tests/QtAutomoc/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <steveire@gmail.com>2013-05-15 17:17:41 (GMT)
committerStephen Kelly <steveire@gmail.com>2013-05-15 17:24:18 (GMT)
commit5c0f2a131f358ac11da52a919f637b57d34cc544 (patch)
tree9750c919a1e9ba333516a02a411d6f7562c52249 /Tests/QtAutomoc/CMakeLists.txt
parent6489015c75367493c9ea6a7bea69b67a88972651 (diff)
downloadCMake-5c0f2a131f358ac11da52a919f637b57d34cc544.zip
CMake-5c0f2a131f358ac11da52a919f637b57d34cc544.tar.gz
CMake-5c0f2a131f358ac11da52a919f637b57d34cc544.tar.bz2
Test the use of target transitive compile definitions with moc.
Diffstat (limited to 'Tests/QtAutomoc/CMakeLists.txt')
-rw-r--r--Tests/QtAutomoc/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/QtAutomoc/CMakeLists.txt b/Tests/QtAutomoc/CMakeLists.txt
index 49d433f..a18baef 100644
--- a/Tests/QtAutomoc/CMakeLists.txt
+++ b/Tests/QtAutomoc/CMakeLists.txt
@@ -5,6 +5,9 @@ project(QtAutomoc)
if (QT_TEST_VERSION STREQUAL 4)
find_package(Qt4 REQUIRED)
+ # Include this directory before using the UseQt4 file.
+ add_subdirectory(defines_test)
+
include(UseQt4)
set(QT_QTCORE_TARGET Qt4::QtCore)