summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CMP0152/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Maynard <rmaynard@nvidia.com>2023-06-29 19:24:49 (GMT)
committerRobert Maynard <rmaynard@nvidia.com>2023-07-20 21:02:58 (GMT)
commit6b5f2dbbfe453f9bafe46ee420e657735ff16fb0 (patch)
treea27c2718ea6c2ddd76e75b35eb035cfc48a0b358 /Tests/RunCMake/CMP0152/CMakeLists.txt
parentb0054dd65c1d69a437abe85d27e704326884a9c2 (diff)
downloadCMake-6b5f2dbbfe453f9bafe46ee420e657735ff16fb0.zip
CMake-6b5f2dbbfe453f9bafe46ee420e657735ff16fb0.tar.gz
CMake-6b5f2dbbfe453f9bafe46ee420e657735ff16fb0.tar.bz2
file(REAL_PATH): resolve symlinks before '..' components
Previously REAL_PATH would collapse paths before resolving any symlinks so if `..` crossed a symlink the output from `REAL_PATH` would be wrong. It looked like REAL_PATH did this by mistake since it was a side-effect of ensuring we had an absolute path before resolving symlinks.
Diffstat (limited to 'Tests/RunCMake/CMP0152/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CMP0152/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/RunCMake/CMP0152/CMakeLists.txt b/Tests/RunCMake/CMP0152/CMakeLists.txt
new file mode 100644
index 0000000..5ff8d3e
--- /dev/null
+++ b/Tests/RunCMake/CMP0152/CMakeLists.txt
@@ -0,0 +1,3 @@
+cmake_minimum_required(VERSION 3.23)
+project(${RunCMake_TEST} NONE)
+include(${RunCMake_TEST}.cmake)