summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-09-05 18:25:27 (GMT)
committerBrad King <brad.king@kitware.com>2014-09-05 18:38:05 (GMT)
commit0f1f1271e6ddcea9074afe79685a731d4295c1f5 (patch)
tree4012664a0c9ff485740fe5bf4a5982072597f323 /Tests/RunCMake/CMakeLists.txt
parent4f7d0c421abf047c052cb8d459c8249310cf4f3a (diff)
downloadCMake-0f1f1271e6ddcea9074afe79685a731d4295c1f5.zip
CMake-0f1f1271e6ddcea9074afe79685a731d4295c1f5.tar.gz
CMake-0f1f1271e6ddcea9074afe79685a731d4295c1f5.tar.bz2
CMake: Add CMAKE_GENERATOR_PLATFORM option
Reject the option by default. It will be implemented on a per-generator basis. Pass the setting into try_compile project generation. Add cache entry CMAKE_GENERATOR_PLATFORM and associated variable documentation to hold the value persistently. Add a RunCMake.GeneratorPlatform test to cover basic use cases for the option. Verify that CMAKE_GENERATOR_PLATFORM is empty by default, and that it is rejected when the generator does not support a user setting.
Diffstat (limited to 'Tests/RunCMake/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/RunCMake/CMakeLists.txt b/Tests/RunCMake/CMakeLists.txt
index 3cd9947..d52a2b6 100644
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
@@ -58,6 +58,7 @@ add_RunCMake_test(ExternalData)
add_RunCMake_test(FeatureSummary)
add_RunCMake_test(FPHSA)
add_RunCMake_test(GeneratorExpression)
+add_RunCMake_test(GeneratorPlatform)
add_RunCMake_test(GeneratorToolset)
add_RunCMake_test(TargetPropertyGeneratorExpressions)
add_RunCMake_test(Languages)