summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniele E. Domenichelli <ddomenichelli@drdanz.it>2017-01-25 09:19:00 (GMT)
committerDaniele E. Domenichelli <ddomenichelli@drdanz.it>2017-01-25 09:20:35 (GMT)
commit4bc2c16b5d01a66c00100171ad083e9ab5a6506c (patch)
tree5f00afe66f51f9833c852b86928ac7aed83d284c /Tests/RunCMake/CMakeLists.txt
parent9702b3eefd2baccd24eea9779e17da8fc143fa4c (diff)
downloadCMake-4bc2c16b5d01a66c00100171ad083e9ab5a6506c.zip
CMake-4bc2c16b5d01a66c00100171ad083e9ab5a6506c.tar.gz
CMake-4bc2c16b5d01a66c00100171ad083e9ab5a6506c.tar.bz2
FindGTK2: Add unit test to check variables when run twice
Diffstat (limited to 'Tests/RunCMake/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/Tests/RunCMake/CMakeLists.txt b/Tests/RunCMake/CMakeLists.txt
index a43e47b..6145615 100644
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
@@ -255,6 +255,11 @@ if(PKG_CONFIG_FOUND)
add_RunCMake_test(FindPkgConfig)
endif()
+find_package(GTK2 QUIET)
+if (GTK2_FOUND)
+ add_RunCMake_test(FindGTK2)
+endif()
+
if("${CMAKE_GENERATOR}" MATCHES "Visual Studio")
add_RunCMake_test(include_external_msproject)
if("${CMAKE_GENERATOR}" MATCHES "Visual Studio ([789]|10)" AND NOT CMAKE_VS_DEVENV_COMMAND)