summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2015-09-08 14:24:36 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2015-09-08 14:24:36 (GMT)
commit4da3315db365f3c80ce5202047955f0f2ec9312f (patch)
tree0446f74abab8d3a7a15996e27747d45f1a884c05 /Tests/RunCMake/CMakeLists.txt
parent20b7e79d211589eed2668474966e77d00025eb37 (diff)
parent8ea7611bc3650c75c86d22a3127cb117dbcaa9be (diff)
downloadCMake-4da3315db365f3c80ce5202047955f0f2ec9312f.zip
CMake-4da3315db365f3c80ce5202047955f0f2ec9312f.tar.gz
CMake-4da3315db365f3c80ce5202047955f0f2ec9312f.tar.bz2
Merge topic 'find_program-NAMES_PER_DIR'
8ea7611b find_program: Optionally consider all names in each directory fc1990c9 cmFindProgramCommand: Re-implement search using more flexible approach fdbfc9f6 Tests: Add explicit testing for find_program 907a919b cmSystemTools: Drop unused StringEndsWith method ed4de3c9 cmFindProgramCommand: Use Names member instead of passing it bf32b95e cmFindLibraryCommand: Avoid repeating search for the same name
Diffstat (limited to 'Tests/RunCMake/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/RunCMake/CMakeLists.txt b/Tests/RunCMake/CMakeLists.txt
index 4d96866..241cf90 100644
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
@@ -184,6 +184,7 @@ add_RunCMake_test(find_file)
add_RunCMake_test(find_library)
add_RunCMake_test(find_package)
add_RunCMake_test(find_path)
+add_RunCMake_test(find_program -DCMAKE_SYSTEM_NAME=${CMAKE_SYSTEM_NAME})
add_RunCMake_test(get_filename_component)
add_RunCMake_test(get_property)
add_RunCMake_test(if)