summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2013-10-18 15:25:49 (GMT)
committerBrad King <brad.king@kitware.com>2013-10-23 12:54:31 (GMT)
commit7d47c693650672afabc46bd200246eb9130582d6 (patch)
tree0a1ad731d0622c629584a6518e124dfb8e7b5661 /Tests/RunCMake/CMakeLists.txt
parentc7c44fc7f4a32163b9fd82e5560fa35df60d2fb4 (diff)
downloadCMake-7d47c693650672afabc46bd200246eb9130582d6.zip
CMake-7d47c693650672afabc46bd200246eb9130582d6.tar.gz
CMake-7d47c693650672afabc46bd200246eb9130582d6.tar.bz2
Drop compatibility with CMake < 2.4
Drop all behavior activated by setting CMAKE_BACKWARDS_COMPATIBILITY to a value lower than 2.4, and generate an error when projects or the user attempt to do so. In the error suggest using a CMake 2.8.x release. Teach cmake_minimum_required to warn about projects that do not require at least CMake 2.4. They are not supported by CMake >= 3.0. Replace the documentation of CMAKE_BACKWARDS_COMPATIBILITY with a reference to policy CMP0001.
Diffstat (limited to 'Tests/RunCMake/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/RunCMake/CMakeLists.txt b/Tests/RunCMake/CMakeLists.txt
index 8148cb6..e84aba2 100644
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
@@ -93,6 +93,7 @@ add_RunCMake_test(Syntax)
add_RunCMake_test(add_dependencies)
add_RunCMake_test(build_command)
+add_RunCMake_test(cmake_minimum_required)
add_RunCMake_test(find_package)
add_RunCMake_test(get_filename_component)
add_RunCMake_test(if)