summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2013-10-18 15:54:09 (GMT)
committerBrad King <brad.king@kitware.com>2013-10-22 13:09:51 (GMT)
commit882c0f0b698e70be8b74aa498b62cb1fb22f3c24 (patch)
tree9154c655d59026c3ccf89b72f8e34da36694939d /Tests/RunCMake/CMakeLists.txt
parentddef8a7cfffbbae12f2d2c556651f06346237569 (diff)
downloadCMake-882c0f0b698e70be8b74aa498b62cb1fb22f3c24.zip
CMake-882c0f0b698e70be8b74aa498b62cb1fb22f3c24.tar.gz
CMake-882c0f0b698e70be8b74aa498b62cb1fb22f3c24.tar.bz2
Add infrastructure for policies that disallow commands
Add cmCommand::Disallowed helper to check the setting of a policy that disallows the command. Add a RunCMake.DisallowedCommands test placeholder. Add a Help/policy/DISALLOWED_COMMAND.txt file for inclusion by each policy document to avoid duplication of the common text.
Diffstat (limited to 'Tests/RunCMake/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/RunCMake/CMakeLists.txt b/Tests/RunCMake/CMakeLists.txt
index 3a0ea91..8148cb6 100644
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
@@ -61,6 +61,7 @@ if(UNIX AND "${CMAKE_TEST_GENERATOR}" MATCHES "Unix Makefiles")
add_RunCMake_test(CompilerChange)
endif()
add_RunCMake_test(Configure)
+add_RunCMake_test(DisallowedCommands)
add_RunCMake_test(ExternalData)
add_RunCMake_test(FPHSA)
add_RunCMake_test(GeneratorExpression)