summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2017-01-25 13:41:18 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2017-01-25 13:41:18 (GMT)
commit4f37987e3fd72b957d45e741e6ee70ccf42b167d (patch)
treec8310c3aea7cea7e819e012679b845db55faa5ac /Tests/RunCMake/CMakeLists.txt
parent9006ec1d9b7d738f690c32d673443b8851887f16 (diff)
parent0618ddf6b1da3a886f12b6ad2b19da49b2f87e28 (diff)
downloadCMake-4f37987e3fd72b957d45e741e6ee70ccf42b167d.zip
CMake-4f37987e3fd72b957d45e741e6ee70ccf42b167d.tar.gz
CMake-4f37987e3fd72b957d45e741e6ee70ccf42b167d.tar.bz2
Merge topic 'lang_lint'
0618ddf6 Add properties to run the cpplint style checker with the compiler
Diffstat (limited to 'Tests/RunCMake/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Tests/RunCMake/CMakeLists.txt b/Tests/RunCMake/CMakeLists.txt
index a43e47b..7e16d0e 100644
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
@@ -340,8 +340,10 @@ if("${CMAKE_GENERATOR}" MATCHES "Make|Ninja")
endif()
add_executable(pseudo_tidy pseudo_tidy.c)
add_executable(pseudo_iwyu pseudo_iwyu.c)
+ add_executable(pseudo_cpplint pseudo_cpplint.c)
add_RunCMake_test(ClangTidy -DPSEUDO_TIDY=$<TARGET_FILE:pseudo_tidy>)
add_RunCMake_test(IncludeWhatYouUse -DPSEUDO_IWYU=$<TARGET_FILE:pseudo_iwyu>)
+ add_RunCMake_test(Cpplint -DPSEUDO_CPPLINT=$<TARGET_FILE:pseudo_cpplint>)
add_RunCMake_test(CompilerLauncher)
endif()