summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2019-01-09 19:30:10 (GMT)
committerBrad King <brad.king@kitware.com>2019-01-11 16:04:51 (GMT)
commit57e48f16f2c3b73fb27057267c8092a41005bb75 (patch)
treea4ffcf1bb1bcb8186ca7504cadd1ad5618852f50 /Tests/RunCMake/CMakeLists.txt
parentbdef729646a5a559c295ef9c0fb83eb8a6b34905 (diff)
downloadCMake-57e48f16f2c3b73fb27057267c8092a41005bb75.zip
CMake-57e48f16f2c3b73fb27057267c8092a41005bb75.tar.gz
CMake-57e48f16f2c3b73fb27057267c8092a41005bb75.tar.bz2
VS: Add Visual Studio 16 2019 generator
Add this generator *without* support for specifying the target architecture in the generator name. cmake-gui will be taught to provide a field for this, and command-line builds can use -A. Also, teach this generator to select a default target architecture based on the host architecture. Fixes: #18689 Inspired-by: Egor Pugin <egor.pugin@gmail.com>
Diffstat (limited to 'Tests/RunCMake/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/RunCMake/CMakeLists.txt b/Tests/RunCMake/CMakeLists.txt
index 5afa242..2b6519a 100644
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
@@ -334,7 +334,7 @@ if (GTK2_FOUND)
endif()
if("${CMAKE_GENERATOR}" MATCHES "Visual Studio")
- add_RunCMake_test(include_external_msproject)
+ add_RunCMake_test(include_external_msproject -DVS_PLATFORM_NAME=${CMAKE_VS_PLATFORM_NAME})
if("${CMAKE_GENERATOR}" MATCHES "Visual Studio (9|10)" AND NOT CMAKE_VS_DEVENV_COMMAND)
set(NO_USE_FOLDERS 1)
endif()