summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2016-03-09 14:42:18 (GMT)
committerBrad King <brad.king@kitware.com>2016-03-09 14:42:18 (GMT)
commitb42866a34a742f89a35382d17d58070c73486d92 (patch)
tree5728aef86df7ff0d6a677875b442d12147da2e46 /Tests/RunCMake/CMakeLists.txt
parentcd9ba3ec453d547b15ab761e20793a1a17bbbd8d (diff)
downloadCMake-b42866a34a742f89a35382d17d58070c73486d92.zip
CMake-b42866a34a742f89a35382d17d58070c73486d92.tar.gz
CMake-b42866a34a742f89a35382d17d58070c73486d92.tar.bz2
Drop Visual Studio 6 generator
This generator has been deprecated since CMake 3.3. Remove it. Update documentation, modules, and tests to drop content specific to this generator.
Diffstat (limited to 'Tests/RunCMake/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/Tests/RunCMake/CMakeLists.txt b/Tests/RunCMake/CMakeLists.txt
index 23b9b42..588f3a1 100644
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
@@ -232,12 +232,12 @@ if(PKG_CONFIG_FOUND)
add_RunCMake_test(FindPkgConfig)
endif()
-if("${CMAKE_GENERATOR}" MATCHES "Visual Studio [^6]")
+if("${CMAKE_GENERATOR}" MATCHES "Visual Studio")
add_RunCMake_test(include_external_msproject)
add_RunCMake_test(SolutionGlobalSections)
endif()
-if("${CMAKE_GENERATOR}" MATCHES "Visual Studio ([^6789]|[6789][0-9])")
+if("${CMAKE_GENERATOR}" MATCHES "Visual Studio ([^789]|[789][0-9])")
add_RunCMake_test(VS10Project)
endif()