summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Stürmer <michael.stuermer@schaeffler.com>2017-06-22 19:40:48 (GMT)
committerMichael Stürmer <michael.stuermer@schaeffler.com>2017-06-22 19:40:48 (GMT)
commitec409a116fd58a541a7700df12dfdfc045f0df17 (patch)
treef0e77b21d224fc9d0c511c3217995207f8338ff7 /Tests/RunCMake/CMakeLists.txt
parentdcdab5cf23b3777761d6c6dcaf0dfcefdd821792 (diff)
downloadCMake-ec409a116fd58a541a7700df12dfdfc045f0df17.zip
CMake-ec409a116fd58a541a7700df12dfdfc045f0df17.tar.gz
CMake-ec409a116fd58a541a7700df12dfdfc045f0df17.tar.bz2
Vs: fix CSharp custom command by introducing inline MSBuild <Targets>s
The custom command implementation is based on the Microsoft support article: https://docs.microsoft.com/en-us/visualstudio/msbuild/how-to-extend-the-visual-studio-build-process Fixes: #16960
Diffstat (limited to 'Tests/RunCMake/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/RunCMake/CMakeLists.txt b/Tests/RunCMake/CMakeLists.txt
index 0369fa4..702ca17 100644
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
@@ -376,3 +376,7 @@ if(CMake_TEST_ANDROID_NDK OR CMake_TEST_ANDROID_STANDALONE_TOOLCHAIN)
endif()
set_property(TEST RunCMake.Android PROPERTY TIMEOUT ${CMake_TEST_ANDROID_TIMEOUT})
endif()
+
+if(${CMAKE_GENERATOR} MATCHES "Visual Studio ([^89]|[89][0-9])")
+ add_RunCMake_test(CSharpCustomCommand)
+endif()