summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CMakeLists.txt
diff options
context:
space:
mode:
authorTaylor Braun-Jones <taylor@braun-jones.org>2016-03-21 20:01:20 (GMT)
committerBrad King <brad.king@kitware.com>2016-03-23 17:22:15 (GMT)
commitf069be054833f465ab469b534fddbc52c5c9913b (patch)
treecef4fffdbd67374055d67a7ce9c2f918c68f9fec /Tests/RunCMake/CMakeLists.txt
parentc05ea48545f04dee8666094b0731366b64dfc9ad (diff)
downloadCMake-f069be054833f465ab469b534fddbc52c5c9913b.zip
CMake-f069be054833f465ab469b534fddbc52c5c9913b.tar.gz
CMake-f069be054833f465ab469b534fddbc52c5c9913b.tar.bz2
VS: Fix default target support for targets nested inside a folder
It's not actually the first target in a `.sln` file that is treated as the default startup project, but rather the first fully defined target.
Diffstat (limited to 'Tests/RunCMake/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/Tests/RunCMake/CMakeLists.txt b/Tests/RunCMake/CMakeLists.txt
index c7fe649..0207753 100644
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
@@ -234,7 +234,10 @@ endif()
if("${CMAKE_GENERATOR}" MATCHES "Visual Studio")
add_RunCMake_test(include_external_msproject)
- add_RunCMake_test(VSSolution)
+ if("${CMAKE_GENERATOR}" MATCHES "Visual Studio ([789]|10)" AND NOT CMAKE_VS_DEVENV_COMMAND)
+ set(NO_USE_FOLDERS 1)
+ endif()
+ add_RunCMake_test(VSSolution -DNO_USE_FOLDERS=${NO_USE_FOLDERS})
endif()
if("${CMAKE_GENERATOR}" MATCHES "Visual Studio ([^789]|[789][0-9])")