summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2018-11-15 13:03:57 (GMT)
committerBrad King <brad.king@kitware.com>2018-11-15 13:08:56 (GMT)
commit86e8315482fd8f0bba85af6f4f8363ead6a0818d (patch)
treebfe834ba2f4f8a613e757c1e775777430063b085 /Tests/RunCMake/CMakeLists.txt
parentbdec3bd896b6faabab1c7cae79d8e75e8d0f0e41 (diff)
downloadCMake-86e8315482fd8f0bba85af6f4f8363ead6a0818d.zip
CMake-86e8315482fd8f0bba85af6f4f8363ead6a0818d.tar.gz
CMake-86e8315482fd8f0bba85af6f4f8363ead6a0818d.tar.bz2
CTest: Restore inheritance of stdin by test processes
Since commit v3.11.0-rc1~117^2 (CTest: Re-implement test process handling using libuv, 2017-12-10) we do not give the child test processes any stdin. Prior to that change we let the child test processes inherit stdin from ctest itself. Tests that run serially might be able to use the real stdin meaningfully, so restore that behavior and add a test case. Fixes: #18591
Diffstat (limited to 'Tests/RunCMake/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/Tests/RunCMake/CMakeLists.txt b/Tests/RunCMake/CMakeLists.txt
index ecd4441..99f4ae7 100644
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
@@ -368,7 +368,8 @@ add_RunCMake_test(FetchContent)
if(NOT CMake_TEST_EXTERNAL_CMAKE)
set(CTestCommandLine_ARGS -DTEST_AFFINITY=$<TARGET_FILE:testAffinity>)
endif()
-add_RunCMake_test(CTestCommandLine)
+add_executable(print_stdin print_stdin.c)
+add_RunCMake_test(CTestCommandLine -DTEST_PRINT_STDIN=$<TARGET_FILE:print_stdin>)
add_RunCMake_test(CacheNewline)
# Only run this test on unix platforms that support
# symbolic links